<UI Studio>Error Message got after upgrade to 3.0

Dear All,

My studio upgraded to 3.0 version today.
After the upgraded, the got messages as below when i tried to run my script with the new version.

And the variables with “Generic Value” Type got type undefined errors.

I tried to run it with 2.4 version that work fine before, but the same errors were met.

How can i resolve it? Any support will be appreciated.

Hi @Toby

You will have to install two package for this System and UiAutomation

UiPath.Core.Activities packages now has been split into two

When migrating a project by opening it in Studio 18.3 the Core package is split into the System and UIAutomation packages. In the Dependencies panel, these two packages are marked as 18.3, which is an incomplete version, as it lacks the Patch number

Thanks,
Prankur

Dear Prankur,

Appreicate a lot for your support.

To be avoid any risk, i prefer to run my project with 18.2.4 version.

I have unstall the 18.3 version and re-install the 18.2.4 version.
After that, i still can’t run my project with same errort such as foreachrow activity can’t be find.

I have no idea about this situation, what should i do?

Hello !
You can follow the below step:
Open the Main.xaml with editPlus3 or other text editor.
Find this sentence: CurrentIndex="{x:Null}"
And delete it.
Finally save the file.
Finally finally open it and see if there is any surprise,
Thanks