<For Each Row> Activity can't be loaded with error message

Dear All,

My UIStudio has been upgraded to 18.3 today, after that my project can’t run with for each row messsage.
•Could not find member ‘CurrentIndex’ in type 'http://schemas.uipath.com/workflow/activities:ForEachRow
•Could not find member ‘CurrentIndex’ in type ‘http://schemas.uipath.com/workflow/activities:ForEach(DataRow)’

5 projects were impacted by the same error.

To avoid any risks with new verison, i unstall the 18.3 version and re-install 18.2.4 version.
But the above messages still be found.

Could you please provide your suggestions to me about it?

This is error message picture for your reference.

To fix it you can edit the .xaml and erase the line with CurrentIndex, seach it in the Row number and Column number that error is giving you

Or maybe you need to update some activity… Try both

Bests,
Pablo

Hi Pablo,

Thanks for your suggestion.
I try to edit the .xmal with the error, but the related activities was displayed as warning message that can’t be edit.

Hi Toby,

if you developed your project in 18.3 version?
Then ,some activities are not supported in the lower version(18.2 likewise).

Hi Sob,

Those projects were developed in 18.2.4 version.
I have attach the source code for your reference. V1.2.zip (357.7 KB)

Hi Toby,

I can able to see all your for each activity in your code. I didn’t face any warning message from your xaml file…

Which version you are using now?
Have you installed all the packages from the “Manage Packages”?

Hi Sob,

May i know the version?
And could you please try to execute it?

Hi Sob,

I have tried to run this project in 3 PCs those can execute this project successfully before.

2 of 3 failed and 1 successed, the failed errores i have attached in the floor 1.

I’m using 18.3 version.
For executing , i need to change all the path in your program.

All the Pc’s are updated( 18.3 ) version ?

Yes, all PCs are upgraded to 18.3 version.

Have you installed all the packages ?
check all the activities inside the app data folder , compare both system(correct output system with wrong output system )

Which one you selected ,stable or beta.?
If possible select stable version from the help

image

Hi Sob,

To be sure the project can be executed without any risk.
I execute the project by 18.2.4 version not 18.3.

I have take screenshot from 2 PC - 1 work fine and 1 failed about the version, package and error message.

PC1 that work fine


PC2 that failed

From your screenshot , you are using 18.2.4 Version.

Try to update 18.3 and check once. I’m not sure , try once

Hi Sob,

Yes, it work fine in 18.3 but we still request to execute the project in 18.2.4 version to avoid any risks.
Do you have any ideas about it?

Great!!!

You can use 18.3 version(ie. stable version instead of Beta version).
No issue in it.

:slight_smile:

Hello !
You can follow the below step:
Open the Main.xaml with editPlus3 or other text editor.
Find this sentence: CurrentIndex="{x:Null}"
And delete it.


Finally save the file.
Finally finally open it and see if there is any surprise,
Thanks

1 Like

@Toby
Step1: Close UiPath and open the xaml file in the notepad.
Step2: Find something like CurrentIndex="{X:Null}"; search and delete occurrences in the notepad and save the file by pressing ctrl+s to close it.
Step3: Open the xaml file in UiPath.

Note: Don’t forget to ‘Update’ all your packages & ‘Install’ all that you see under ‘Available’ tab in ‘Manage Packages’ option.