Core activity not found in Manage Packages although UiPath.Core.Activities.2018.3.6848.19350 file is in the packages folder of UiPath

UiPath has been update to 2018.3.0, since the update I am receiving errors “Could not find type ‘UiPath.Activities.ReadCellsRange’ in assembly ‘UiPath.Activities’. Row: 99, Column: 10” although UiPath.Excel.Activities is installed.

Current Behavior: I am receiving errors “Could not find type ‘UiPath.Activities.ReadCellsRange’ in assembly ‘UiPath.Activities’. Row: 99, Column: 10” although UiPath.Excel.Activities is installed.

Expected Behavior: What can be done to solve this issue? Also, in the Manage Package, ‘Local’ or anywhere else, I can not see UiPath.Core.activities anywhere althought it is in the root folder “Packages”.

Studio/Robot/Orchestrator Version:app-18.3.0

1 Like

@ovi Do you have any clue how I could solve this issue please?

first of all, i m not sure i understand your problem: you have an workflow with excel activities and when you run it from Studio, you get that error - even if you have the excel package installed?

I have 2 problems, 1. UiPath.Core.Activities is not visible on the manage packages and 2. yes, you’re right, I get that error even when I have excel package installed.

core activities now are split into two new packages
on the excel workflow, i suspect you have an older version of excel package installed, try upgrading to latest release - 2.3.xyz

1 Like

That make sense, thank you for clarifying that. I have checked both activities are installed to the latest version. What can I do to solve the error I am getting?

can i see the Project wizard, screenshot please

Is it this you are asking for?

yes. right click on the red ones and choose Repair. you don`t have all the required packages installed.
but before doing that, maje sure you have all the feeds you have used in the past

I have tried to repair the core activity highlighted in red, but It has not done anything. Sorry about this, I appreciate you taking your time out to help me with this.

that core 1.0.0 package should not be there. is it still not working after repair?
if you manually install those two core packages and excel from package manager, it will work?

I have deleted core 1.0.0 and after repair still not working

what errors do you see now, same?

This is the error i get after trying to repair core 1.0.0 package

what is that package? a custom one?

I have deleted that package as well now, still getting the same error

you will need to install that package from a local feed, the missing one
system private uri 4.0.0

Which package should I install sorry? These are the error I am getting still:

image

Hello Haich,

I have the exact same issue, did you manage to solve yours?
Thanks!

Tom