Copy sheet exception: HRESULT 0x800A03EC only on a specific sheet

So I have this excel file that I am running on a lower Uipath version(2019). It has multiple sheets in it and I am looping through all of them. My Process is, after analyzing the sheet, it would copy it into a new excel file then sheet name called “Source”. My Problem is, when this certain sheet is in process, copy the “Source” sheet gives the HRESULT Error. I think this isn’t about the background excel running issue. Because the other sheets in the file works well with processing it, copying it, then copy the “Source” Sheet. Only in this specific sheet that it gives the error. I really don’t know what to do.

Hi,

How are you copying the Excel sheets? Could you share the Code/sequence?

I had problems when I left the Excel in the background, both excels have to be in foreground. It could be that maybe the sheet you are trying to copy is protected?

First, I read the excel file using the Excel Application scope. Then, I read all the sheets of it, import it in my invoke workflow together with the WorkBook variable of the first excel application scope. In the invoke workflow. I use the excel application scope again but without entering the file name but instead, use the imported workbook variable.

In the new excel application scope, I copy the sheet of the sheet in process, and the source file sheet. The output is a string variable with the filepath of the new file, it automatically creates it. I have no problem with the first copy sheet in the new excel application scope, the problem only appears in the second copy sheet(source sheet). I thought it was because of the background excel running, but the other sheets works good when copying the “Source” sheet.

@Archie Put some delays between your excel activities will resolve the problem.

Tried putting 5 secs delay in between copy sheets. Still the same, I retry it again with a longer time