Connector.Salesforce.Activities


#1

Executes Salesforce SOQL Query and Stores the result in an Output DataTable.

Contains 2 Activities:

  1. ExecuteSOQL_PROD - To Execute the SOQL Query on Production Instances. (e.g. login.salesforce.com)
  2. ExecuteSOQL_SANDBOX - To Execute the SOQL Query on Sandbox Instances (e.g. test.salesforce.com)

Note: This is designed based on Partner WSDL from Salesforce.

Package: Connector.Salesforce.Activities
Author: @Rammohan91


#2

I tried using this connector just to do a simple query and I keep getting an Index was out of range error. All I am doing is requesting to get the AccountID of a case number. The query is as follows:

SELECT AccountId FROM Case WHERE CaseNumber = ‘13305572’

I’m not quite sure what the problem would be. I have created a datatable called tblSaleforce. I created the table directly from the OutputDataTable variable creator from within the activity.


#3

Hey @rodwaymore,

I got the issue.

Thanks for pointing :slight_smile: I will fix that and will update the package.

Thanks,
Rammohan B.


#4

@rodwaymore Here is the updated package,

Connector.Salesforce.Activities.1.0.3.nupkg (148.6 KB)

@ovi @badita I am not finding a way to update the package in UiPath Gallery. Do i have to delete the existing package and upload the latest one again? Can’t i just update the latest version of the package.


#5

The feed it’s called Community in CE. https://gallery.uipath.com/api/v2


#6

@badita Actually, i just fixed a bug for that custom activity and would like to upload the latest version on gallery.uipath.com

I don’t see a way to update 1.0.2 with the latest 1.0.3.

Thanks,
Rammohan B.


#7

Hi @Rammohan91,

You can update it by these following steps.

  1. Do the copy paste the old directory (which you keep the nuget package and dlls) and rename with the new version number .
  2. Open the “nupkg” file with NuGet Package Explorer from the new directory.
  3. In the Package meta data - > Except the id you can change all the things.
  4. you can change the version number 1.0.3 . Click the green tick in the top.
    5.if you have changes in the package content. you can do.
    6.Finally do the **Save As **. and upload into the https://gallery.uipath.com

Regards
Balamurugan


#8

Thanks for the reply @balupad14

I already have 1.0.2 uploaded into gallery.uipath.com, do you mean that uploading again with 1.0.3 will overwrite the existing package there with the latest one.

Thanks,
Rammohan B.


#9

@Rammohan91 Thank you!! Thank you!! You don’t know how much this activity was needed. You wouldn’t by chance be working on an activity that could mimic the Salesforce workbench activities like Update, Insert, etc. by using a file? :wink:


#10

Hi @Rammohan91 ,

It won’t overwrite.It will be added a new version. It keeps the older version.

Regards
Balamurugan


#11

Thank you. Glad that its helpful for you.:slight_smile:

Haven’t checked yet, will see if there are api’s from salesforce that can be utilized.

Thanks,
Rammohan B.


#12

Thank you @balupad14 It worked. :slight_smile:

Thanks,
Rammohan B.


#13

@rodwaymore You may want to have a look at the activities i just added to this custom activity.

2 more custom activities are now available ‘Insert Record PROD’ & ‘Insert Record SANDBOX’ for the package. I just tested it and the insertion of the record works perfectly for me. I would be happy if you can test it on your end since you requested it first :slight_smile: I will try to create one soon for update as well.

Note:
Field Names, Field Values are string arrays and Object Name is String. Follow as below:
image

Thanks,
Rammohan B.


Sales Force Login and Account Creation Activity
#14

Wow!!! I really didn’t expect such a fast turnaround on this. I’ll check it out right now and get right back you! You REALLY don’t know how helpful this will be for the Salesforce project we are working on.


#15

I tried Inserting a case but I get an “Index was out of range” error.

The Salesforce FieldNames names are
{“AccountID”,“ContactID”,“Type”,“Center_of_Excellence__c”,“Origin”,“Subject”,“Description”,“RecordTypeID”,“IsVisibleInSelfService”,“Status”,“OwnerID”}

The FieldValues that I am using are:
{“xxxxxxxxxx”,“xxxxxxxx”,“Orders”,“Partner Services & Operations”,“EDU ARC Automation”,"**This is a test EDU ARC Order. It will be deleted by RPA Team. DISREGARD",“This is a test description”,“Order Support”,“FALSE”,“Open - Unassigned”,“Partner Services & Operations”}

I removed the actual AccountID number and ContactID numbers and replaced with “x” in this communication so those values are actually numbers.

The ObjectName is “Case”


#16

Hey @rodwaymore, Thank you so much for testing that. I was hard coding the array size of FieldNames. Its now dynamic and takes the length from the FieldNames property. It should work now. Fix 1.0.6 updated on the gallery now.

Thanks,
Rammohan B.


#17

I have setup the automation to display the RecordID output in a message box and now I am getting the following for RecordID:

~Rodney~


#18

Just for clarification…Order Support is the value that I currently use if I was creating a case via the workbench for the RecordTypeID field.


#19

Hey @rodwaymore, Is ‘Order Support’ a Record Type for that case? Aren’t you suppose to pass the id of the record type instead of the value?


#20

Added 2 more activities to the package - ‘Update Record PROD’ & ‘Update Record SANDBOX’.
Latest Version 1.0.7 has been uploaded to UiPath Gallery.

Properties:
ID - Id of the salesforce record that needs to be updated. VariableType is String.
FieldNames - String Array of Field Names that needs to be updated.
FieldValues - String Array of Field Values that needs to be updated in sync with the FieldNames array.
ObjectName - Object of the Salesforce that would be updated. VariableType is String.

Let me know in case anyone see any issues with these activities.

Would be happy to receive more suggestions for building custom activities that may be needed related to salesforce. :slight_smile:

Thanks,
Rammohan B.