Connector.Salesforce.Activities


#21

@Rammohan91, Order Support is a drop down value that can be selected for the RecordTypeID field. I thought that I was supposed to enter the field value as a string for the field name. The fieldname is RecordTypeID. Are you saying that I need to get the ID number of drop down value instead? This doesn’t seem to be a problem for the other values but let me do some more testing just to make sure this is the only field that I am having a problem with. I will also look at the Update function, too.

Thanks again for all your work on this.


#22

I think I may see what the problem is and it may not be on your side. Let me do a few more tests on my side and I will get back to you in a day or so. Thanks.


#23

For a Picklist Field inside an object, value can be passed directly. However if it’s a RecordType or Lookup Field then the 15 digit salesforce id needs to be passed as the value of that particular field.

Thanks,
Rammohan B.


#24

Would you happen to know an easy way of getting the salesforce ID of a value? The example that I gave earlier was a picklist value so I thought it would have worked but I’m gonna try a couple of things tomorrow. Thanks.


#25

Navigate as below to get the id of the Record Type in your salesforce instance,

Setup -> Build -> Customize -> Cases -> Record Types

You should see your Record Type value ‘Order Support’ under the list in this page. Click on it and select the id value from the URL. It would be in the url as a parameter like https://…?id=<15digitsalesforceid>

Let me know if it works.

Thanks,
Rammohan B.


#26

Unfortunately that doesn’t work. I can see Order Support under Case Record Type but it is not a hyperlinked value so you can’t click on it. I’ll look into this further and get back to you. Thanks.

~Rodney~


#27

Execute this query using ‘Execute SOQL PROD’ Custom Activity.
“Select Id, Name from RecordType”.

This should provide you the list of all the ids and names of record types in your salesforce instance. Look for your ‘Order Support’ Record Type and its associated id.

Let me know in case it works.

Thanks,
Rammohan B.


#28

LOL! I actually thought of that right before I went to sleep last night. I was just so tired I forgot about just doing a query for the id’s. Performing the query works. Thanks.

~Rodney~


#29

Glad that it worked. Thanks :slight_smile:

Thanks,
Rammohan B.


#30

Hi Rammohan -

Thanks for developing this custom package!

I know it’s been a while since this thread was last active and I know this is a really basic request, but I’m hoping you can still help out. I’m really interested in using the activities but I’m struggling since I don’t have much knowledge of queries. Would you mind sharing a sample xaml where you use the Execute and/or Update activities? It’d be immensely helpful to see what a simple application of the activities looks like.

Thanks! Any help is appreciated.


#31

Hey @bdale04,

Thank you so much for showing willingness trying this out.

Here are some samples for Execute, Insert & Update activities. Note that the samples are for Prod Instances. Each of these activities have a similar Sandbox one.

I hope you are already familiar with the salesforce to work with this activity and have a working Prod or Sandbox instance where you may wanna try these activities.

Salesforce_Examples.zip (11.4 KB)

If you don’t have one may be you can create a developer account here:
https://developer.salesforce.com/signup?d=70130000000td6N

Note: I had to replace my password, username, security tokens & ids so it may not directly work for you. You may have to use it according to your instances and objects.

Let me know if it helps.

Thanks,
Rammohan B.


#32

Hi Rammohan,

Thanks for helping with this! What do I do if my instance of Salesforce in Prod is not salesforce.com? What I mean is I log on via the website [CompanyName].my.Salesforce.com. Will resetting my security token allow me to use the new security token to reach the correct instance and use these activities you’ve created? Otherwise how does it know to point to the right instance of Salesforce?

Also, question about Executing a query. This seems like it’d be waaaay better for what I do inside SF currently. I use Salesforce to navigate screens and run reports. Can executing a report return a report I’ve made or return the same fields that I’ve placed inside a report? If so, how do I know the object or find the object? As well as the field names.

Thanks for your help! These seem awesome!


#33

I believe all the salesforce prod instances always goes through https://login.salesforce.com. ‘My Domain’ of salesforce would just be another way to access that instance. Give it a try and let me know if the custom activities doesn’t connect to your salesforce domain.

Unfortunately No. I don’t see a way to get the reports & dashboards data directly. ‘Execute SOQL’ just gets the data in the DataTable type. It works similar to the way you execute the query in Developer Console. If your is just in a tabular structure and you can simulate it as an SOQL Query then it should be good to go. Let me see if there are any operations that can be performed on reports & dashboards through api.

Thanks,
Rammohan B.


#34

Question. Salesforce Execute SOQL in PROD is only pulling 1000 records of 1 million records. Any fix?


#35

Looks like limit is set by salesforce for the SOQL Query through the api. I don’t have that much of data in my sandbox to test. I will try something and see if its possible to get more than that, but that may take some time.

Thanks for bringing that up. Will update you soon if i get something.

Thanks,
Rammohan B.


#36

As i am new in salesforce Technology and i Do not have that much of knowledge.
According to me Do not Overwrite the sql query


#37

@ Rammohan91
I am trying to run the following query : “SELECT id, Name, BillingStreet FROM Account where Name=’” + varAccountName+ “’”

In above query, account name is stored in the ‘varAccountName’ variable.
After executing the query in the Execute SOQL SANDBOX activity, no result is returned. Also no exception is thrown.

Please look into it.
Thanks.


#38

i am trying update data into saleforce using the connector but after calculations, but i think the variable is not passing into the update prod activity. How do i do it?

For reference
if(condition)
then
seq(Assign x = (a - b).tostring ) —> x is string type

salesforce update prod activity(x) ------ {field name - {“xyz”} field values - {a}, ID -id from salesforce query, object name - xyz__c , password …etc}

does salesforce update activity takes only string?
why is value of x is not pasing dynamically?

please suggest.
thanks in advance