Connection between orchestrator and robot

Hi!
I’m connecting the orchestrator, the robot and the studio.
But when I publish in studio, I get ‘Error: Publish of Process project to Orchestrator failed. User does not have any of these permissions: Packages.Create to perform this feed action’
The same goes for orchestrators.
After searching, it seems that the RPA_Robot I made does not have a connection. What should I do in this case?
I entered the machine key well!


@Bobae_Lee

Can you check your Assistant whether it is connected to orchestrator or not?

Thanks

Hi @Bobae_Lee,

To which feed you are trying to publish? Folder level feed or tenant level feed?

Regards
Sonali

Hi @Bobae_Lee

From the screenshot, it seems that the robot is not properly connected with the Orchestrator. May I know which version of Orchestrator you are using and whether you are having trouble connecting it?

Hi @Bobae_Lee,

To reiterate @sonaliaggarwal47, are you trying to publish a tenant or folder level?

You must ensure that the user/robot you are publishing with has the correct role/permission for publishing packages. Please see: Default Roles

Have you create a machine template with an unattended license allocated for this bot connection in Orchestrator and connected via UiPath Assistant? Please see screenshot.

We have a full guide on deploying unattended robots here: Deploying Unattended Robots - Community License or Deploying Unattended Robots - Enterprise License for Enterprise licenses. If you follow this, you should be able to set up a successful connection of your unattended bot with Orchestrator.

Thanks,

Lisa

image

i think it’s connected

@Bobae_Lee

Can you cross check which url it is connected?
Because It is showing as disconnected in orchestrator

Thanks

I’ve tried both.
The folder level feed says the publish was successful, but I can’t find it in the orchestrator package,
Publishing as a tenant-level feed doesn’t work at all.

캡처
I don’t see any problem :frowning:
Where should I check? The machine name is the same and I pasted the URL well…
Ah! My url doesn’t contain an orchestrator.
I know I only have to paste it in Assistant until /Orchestrator.
Maybe my URL is wrong in the first place?

What is the difference between standard and template machines?
I used to build machines only as standard.

Hi @Bobae_Lee,

Could you please share screenshots from Robot tab, machine tab, and under your folder users/machine tabs?

Also if you could confirm if you have created machine template as for modern folder, standard machine doesn’t work.

Please note: If you created modern folder with folder level feed you would still be able to publish packages to tenant level. But if you enabled folder with tenant level feed you can only publish at tenant level.

Regards
Sonali

Hi @Bobae_Lee,

Standard machine: The standard machine key is generated for a single workstation with the same name as given to the standard machine. This is recommended if you want to restrict connecting the UiPath Robot to Orchestrator on a certain machine only, as it works in scenarios in which the machine name stays the same each time you connect to it.

Common usage scenarios:

  • Persistent Virtual Desktop Infrastructures (VDIs) - private workstations where end users use the same workstations day after day.
  • Environments with static machine/user combinations.

Machine Template: The generated key works for any machine on which the UiPath Robot is installed, with no restrictions in terms of machine name, so this can be used for all types of setups, including those in which the name of the workstation changes every time a user logs on to it.

Common usage scenarios:

  • Non-persistent Virtual Desktop Infrastructures (VDIs) - public workstations where the end-user changes frequently.
  • Environments with arbitrary machine/user combinations.

So you can use either one, but if you’re using standard the name of the standard template must match the name of your machine that you see in your UiPath Assistant.

I.E:
This is the machine name in my UiPath Assistant:

and this is my standard machine that is in orchestrator:

If using a Machine Template, you don’t have to worry about these matching.





I’ll show you everything. I’m new to orchestrator, so maybe it’s a mess

Could you please tell me the order in which to design the orchestrator? I want to make it again from scratch!

Hi @Bobae_Lee,

From this screenshot it looks like you have not given yourself any role on the tenant level:


Please give yourself an admin role in this user tab and try publishing again.

It also looks like you are using tenant level packages and not folder level packages. In this case, you have to make sure you have tenant level permissions to publish packages (which can be done if you give yourself admin role). Please see Default Roles for more on UiPath roles.


I’ve only checked with an administrator account so far.
But can’t I see this process in the admin account-package?

It was a permission issue.
It’s too hard. :frowning:
Where can I study this?

I thought you were writing an answer, but I’m sorry. I clicked solve solution

Hi @Bobae_Lee, no worries :grinning: I’m glad that it worked!

I highly recommend checking out our Academy: https://academy.uipath.com/ to learn more about our products and platform. We have several classes on learning more about Orchestrator.

Cheers,

Lisa

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.