Unable to publish process in Orchestrator

Hi Community,
While trying to publish a process on Orchestrator, I am getting this error:

In UiPath Assistant, Status says connected and licensed yet I am unable to publish anything. Please help.



What license is assigned to your bot?

Is it rpa developer or non prod?


I am unable to find the option to check bot permissions. Orchestrator interface seems to be changed again. Can you pls help with steps to check this ? if possible pls provide with screenshots.


Hi @Akshat_Sharma1

In the studio, try checking if you are connected to the orchestrator. It appears at the bottom of the page like shown in the screenshot.
If that shows a green dot then try checking the assistant by opening the assistant and clicking on the initials of your name for example SB in my case and then select preferences and then orchestrator settings and check the connection as shown in the screenshot.
If any one of the 2 is not connected then your system is not connected to the orchestrator and you can login through the assitant and then restart your studio and try to publish.


Hi @Savan_S_Bangoria , Thanks for your elaborated response.
For me in UiPath Assistant its showing as licensed and connected with my name initials AS:

But in UiPath studio at the bottom of the page instead of email id like its coming for you only default option is coming. I remember it used to come fine earlier not sure what has changed now:

I think its due to this default option I am unable to publish anything. Can you pls suggest how to fix this?


Did you recently migrate to modern folder?

Looks like your bot is still pointing to the classic…

Try signing out and sign in again…

Also go to users…and check the user you used to log in and see what license type is present on it…

Did you happen to create the machines and assigned them to the folder?

You can check this in tenant option on orchestrator then go to machines…



Sign in and out I have tried multiple times. User is using attended prod license and i have created new machine and assigned to folder but still the same issue.


Is the user also assigned to same folder?

try using the machine key to connect and check if that resolves the issue

Alternately try disconnecting and then clear the cache and then reconnect and check



Yes user assigned to same folder.
If I try to login from machine key it gives error “Unable to retrieve license.”


After giving machine key you will see sign in option click on it and sign in to orchestrator to retrieve the license

Detailed steps

Alternately try deleting the cache