Connecting Artifactory NuGet Feed to Orchestrator in web.config

We are attempting to connect Orchestrator Packages to a NuGet feed defined in Artifactory.

We placed the URL and API key in the web.config for Orchestrator here:
!–Deployment–>
!–Change the path to the packages folder. Default is ~/NuGetPackages.This can be a virtual path or a subfolder name.–>
add key=“NuGet.Packages.Path” value=“https://SITENAME.com/artifactory/api/nuget/NUGETFEEDNAME” />
add key=“NuGet.Packages.ApiKey” value=“AAAAAAAAAAAAAAAAAAABBBBBBBBBBBBB000001” />
add key=“NuGet.Activities.Path” value="~/NuGetPackages/Activities" />
add key=“NuGet.Activities.ApiKey” value=“AAAAAAAAAAAAAAAAAAABBBBBBBBBBBBB000001” />
add key=“NuGet.EnableFileSystemMonitoring” value=“true” />

However, in Orchestrator, the following message keeps appearing when hitting the “Packages” tab:
“Cannot connect to Packages feed, the URL may be invalid”

Is there a special setting or setup we need to do to make this work?

1 Like

I’ve changed the DeploymentURL and messed around with the settings a bit now. Nothing is working.

Has anyone effectively setup an outside Nuget feed or Artifactory Repo? Would love to get this working.

1 Like

Did you found a solution. How is your project setup. Dou you copy packages by hand to a directory and commit new packages to source control? Or do you upload in orchestrator and commit the directory later? I found no clean solution …

We still don’t have a solution for this unfortunately.

I ended up implementing our own Nuget Server to make this functional:

Hello,


For any external feed deployment, we need to perform the settings in Settings -> Deployment page (not on Web.config, because values should be saved also in DB).
Please check the following steps, depending on the external feed type:

  1. Public feed:
  • Go to Artifactory→Admin→ Security→Security Configuration and check if “Allow Anonymous Access” option is checked.
  • Go to Artifacts→ Your Feed → Set Me Up for you feed and copy the link for your feed like:
  • In Orchestrator, Settings -> Deployment page check “External Deployment” and set to “Deployment URL” the previous link.
  • On Security section, the API Key should be set like “user:password”
  • Save the settings.
  1. Private feed:
  • Go to Artifactory→Admin→ Security→Security Configuration and check if “Allow Anonymous Access” option is NOT checked.
  • Go to Artifacts→ Your Feed → Set Me Up for you feed and copy the link for your feed like:
  • In Orchestrator, Settings -> Deployment page check “External Deployment” and set to “Deployment URL” the previous link.
  • On Security section, the Authentication should be set checked and username& password needs to be provided.
  • Save the settings.
1 Like