Connect to Orchestrator via UiPath Studio

Dear community,

Under Tenant > Robots > Classic Robots

Here it shows the robot is unlicensed.
However, under Tenant > License, I have already added the relevant robot.

image

I have checked the domain\username and they are correct (same as “whoami”).

Now when I try to Connect to Orchestrator via Studio, it keeps showing robot does not exist error.

How I connect: copied the machine key generated & keyed in the Orchestrator URL.
(PS: May I ask how do one normally get the Orchestrator URL?)

Any solutions to how I can connect to orchestrator via Studio?

@Techstop_SG ,

Check robot service and restart it again in the robot machine.

@Techstop_SG

Check below documentation for your reference

Hope this will help you

Thanks

Hi @Techstop_SG,

Can you follow these steps:

There are two ways to solve your issue.
First, with the current settings,

  1. Go to Admin → Tenants → Edit License: Allocate the available license.
  2. Go to Admin → Organization Settings → Advanced Settings (User License Management) → Enable ,if it is disabled.
  3. Go to UiPath Assistant → Preferences → Orchestrator Settings → Connect with Service URL and also same with the studio.

Second, have to connect it using a machine key.

  1. First, disconnect your assistant and select Machine Key option as the connection type and you will find the machine name.
  2. Copy that machine name, and in orchestrator → Tenants → Machine → Create Standard Machine → Machine name should be the name which you copied from the assistant and allocate the license also based on your requirement.
  3. Then, Go to Tenants → Folders → Create Folder (Modern Folder) and once created select the folder in the same screen & select machines → Manage Machine in Folder & select the machine which you have created recently.
  4. Now once allocated, copy the machine key and paste into Assistant and URL is the tenant URL (usually: https://cloud.uipath.com/TenantName/id/orchestrator_) and paste it into the URL field and click connect & it should show as Connected, Licensed
  5. Connect your studio also using Machine key.

This will solve your issue.

Thanks,
@Murli_Manohar