OCR doesn't work in Computer vision

Hi all.
I’ve just installed Computer Vision and all dependencies. But the CV Screen Scope doesn’t work by both manual nor Recording placement. It says: “The OCR engine returned no results. There might be a problem with its configuration.”
Can anyone help?

Thanks.

Hi @Tung_Lam_Nguyen
Could you specify which OCR engine you’re using? I’m asking because I have the same issue for Abbyy OCR, for instance, while standard Microsoft OCR and Tesseract OCR work both well…

I’m using the default Microsoft OCR, and the Tesseract OCR gives the same error.

Try to configure everything as in the screenshots. Hopefully it’ll work!

1 Like

I’ve done all these settings with Microsoft OCR, and scales from 1 to 5 and more. But all the same.

Having the same issue

@Josh_Shapiro @Tung_Lam_Nguyen, could you tell us the versions for Studio, ComputerVision activities, UIAutomation package?

Studio 2019.7.0 Community stable
CV 2.0.0
UIAutomation 19.7.0
UiPath.Vision 1.6.1
OCR.Contracts 2.0.0

With the new CV 2.0.1, the result is the same.
I’ve tried on different computers. And this issue seems to happen not only to me.
Here are dependencies:
Denpendencies
and the workflow:
Main.xaml (23.6 KB)

Hi!

Can you please try to set language for Microsoft OCR to “en” and see if it solves the issue?

1 Like

We’re trying to get to the bottom of this but we can’t really reproduce it.

So a couple of questions:
What’s the value of the Language parameter in the OCR?
What does the content of the Scope look like, is it a whole window or just a small portion, like a textfield?

If you can describe all the steps to reproduce this, it would help.

also, what windows version are you running?

Windows 7 and Windows server 2012

I am getting the same issue. OCR works fine with regular screen scraping though.

But using it in CV Screen scope throws this error. Is it related to being behind a firewall?

It is not related to firewall. It is need to deal with respective OCR engine.
OCR engine is not available.

@SurajK How do I fix it? I tried with all the OCR engines available. The same engines work fine with regular OCR screen scraping.

The problem is partly solved in this topic Computer Vision / OCR configuration error

Hi All,

I tried to automate using CV, but I am getting the same error as it is mentioned above, Is there any proper way to resolve the issue?

OS: Windows Server 12 R2 Standard
UiPath: Community Version 2019.8
AI.ComputerVision 2.1.0
UIAutomation 19.8.0

It would be great if there is any proper solution for this. Thank You!