Computer Vision Get Text returning empty string for one scenario, not always

Hi All,
Hope you can help. Below is a screenshot from Studio where we are using Computer Vision to try and determine the state abbreviation code from a Citrix application’s drop down menu. For some reason, Florida is currently the only state that returns an empty string. Other states we’ve tried return text using Tesseract OCR. The text returned for those states is not perfect, but we are able to perform manipulation to get the two-character code without much trouble. I have altered the selected target on the CV Get Text activity many different ways to identify the text we want. And other OCR engines are not as consistent as Tesseract. The current explanation of “that’s odd” doesn’t work for our users. :blush: Any assistance you can provide is appreciated.

Hello @c-jbring!

It seems that you have trouble getting an answer to your question in the first 24 hours.
Let us give you a few hints and helpful links.

First, make sure you browsed through our Forum FAQ Beginner’s Guide. It will teach you what should be included in your topic.

You can check out some of our resources directly, see below:

  1. Always search first. It is the best way to quickly find your answer. Check out the image icon for that.
    Clicking the options button will let you set more specific topic search filters, i.e. only the ones with a solution.

  2. Topic that contains most common solutions with example project files can be found here.

  3. Read our official documentation where you can find a lot of information and instructions about each of our products:

  4. Watch the videos on our official YouTube channel for more visual tutorials.

  5. Meet us and our users on our Community Slack and ask your question there.

Hopefully this will let you easily find the solution/information you need. Once you have it, we would be happy if you could share your findings here and mark it as a solution. This will help other users find it in the future.

Thank you for helping us build our UiPath Community!

Cheers from your friendly

Hi @c-jbring
It appears the problem is with the OCR Engine not being consistent. Can you please try our UiPath Screen OCR (included in UiPath.OCR.Activities package) and tell us if you have better results?


Can you show us a screenshot with the florida state selected. The Descriptor for the CV Get Text Activity will also help but at a first glance I think it should be an OCR issue.

This worked. Thanks so much for the reply Stefan. I appreciate it.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.