Community Edition Activation Issue Through Proxy

Hi,
Would appreciate any assistance.

I have installed UiPath Community Edition on my work machine but hitting issues with activation:

19:19:52.3490 => [ERROR] [UiPath.Studio.exe] [1] Error: An error occured while sending request to: https://license.uipath.com/api/allocate-license/studio/community with content: System.Net.Http.StringContent Exception: System.Net.Http.HttpRequestException: An error occurred while sending the request. —> System.Net.WebException: The remote server returned an error: (407) Proxy Authentication Required.

I am indeed trying to go through a proxy to activate the license. I’m following the instructions found here:

I know all the details for the values needed inside that snippet. The same values and similar configuration is working just fine with my Java/Maven configuration XML - no issues. I also use the same proxy to in another app to pull down updates and again, it works just fine.

However getting no-where with UiPath. Because the error is a 407 (Authentication required) it makes me think that the config snippet added to license.config is actually doing nothing whatsoever as the proxy is rather saying that that no credentials are being sent at all.

Does that snippet go into a specific line or part of license.config?

Can anyone suggest anything? Is that information up to date? I seem to have two separate license.config files in my installation. I have tried adding that additional proxy config to both files but still no use. Would appreciate any suggestions.

Hi @kryten

I believe the article you’ve linked concerns the Robot connection to Orchestrator and not the Studio activation. You will need to make sure that the request from Studio goes via proxy to this server: https://license.uipath.com.

Actually scratch that, our Studio docs say clearly that the configuration is the same as the Robot page you’ve linked. Let me dig around a bit…

… okay. So first, I would place all the info in both license.config files within the folder with the most recent version number. If this doesn’t work, please gives this a go:

Also, see here for a general remark about connectivity issues during activation:

Many thanks.

No joy yet. I am now trying to use the offline activation process via regutil. Still struggling though…

I’m getting “invalid license code” messages when I try to activate using a generated activation code here:
http://support.uipath.com/activation

When I do a >regutil get-info
I get:
Error #17: Cannot read license code: -1094, error description: NSL not licensed
License status: -1
Device id: Sr7KfcFeIK6erfAlNXTa
Error #20: Cannot read license expire date: -6003, error description: Lookup of tag failed
Maintenance expire date: not set
Subscription expire date: not set
User defined field “Attended”: not defined
User defined field “Unattended”: not defined
User defined field “Free”: not defined
User defined field “Dev”: not defined
User defined field “AttendedConcurrent”: not defined
User defined field “DevConcurrent”: not defined

Now I have no idea whether the “code” param I am using in:

regutil get-activation-cert /email=someone@somewhere.co.uk /code=Sr7KfcFeIK6erfAlNXTa /out_file="C:\apps\uipath\code.txt

Is correct or not. What should that code be? Is that synonymous with the device Id or is is something else? I note that get-info says it cannot read the licence code; I am supposing that is the code I should be using, right? Any ideas how to get that? What does error #17 mean?

Would be grateful for any assistance / guidance here and getting no-where fast right now :frowning:

It is not possible to activate the Community Edition offline. The code field in this case is the actual license code of the Enterprise version.

Does it mean that you had no luck activating Studio by setting up machine-wide proxy?

1 Like

Hi @loginerror

Thanks for the reply.

We are still struggling to activate the Community Edition version of UIPath studio. As such as cannot assess it or make any decisions about how we move forward with it.

I’m not sure what you mean by setting up a “machine wide” proxy? Do you mean adding the XML to the license.config file referenced earlier? If that is what you mean then no… that seems to make zero difference as the proxy just spits out a 407 not authenticated… Even though the username and password is in the XML. So this suggests to me that the data in the XML nodes is not actually being passed to the proxy at all. As mentioned we are using exactly the same proxy to pull down loads of other things via Java Maven. We are using the same username/password with Maven and no issues at all.

Is it possible that the XML goes somewhere else? Could someone post an example of how they used the XML from that page to successfully activate UiPath Studio through a local proxy (anonymise it first though!). I have tried putting the relevant XML data both inside the SHAFERXMLParams block and outside - no difference at all, sadly.

if you mean something else… please share that with me… We have a tonne of automatable cases we would like to try out with UiPath… but these difficulties with activating the Community Edition are killing us.

I would really appreciate some assistance with this if at all possible.
Many thanks!

I was referring to this part of our documentation:
image

It might work in your case. Also, don’t worry, there’s got to be a solution.

As a last resort, you might also try the Trial version of Studio which would allow you to activate it offline.