Community Edition - 2023.4.2 - bug (change in behavior) and performance impact

Community Edition Version 2023.4.2
Activities versions

Firstly When this activity is executed - and this workflow has been running for 14 months - all of a sudden when executing the Excel Sort (within an Excel Scope and Use Excel) it opens Excel at the start section - not an active page (which I can understand better). Disabling this activity will resolve it - but it is a critical portion of the workflow. Closing Excel will cause workflow to continue.

Something has changed that changed behavior unintended.

Secondly - using for each row on a small excel sheet - 100 rows and 10 columns has slowed down by a factor 5. if I run the same workflow in the same data, it looks like this - run 1 6 min, run 2, 7 min, run 3 2 min. (on stand-alone VM). it used to finish in about 90 seconds on average prior

Please investigate.
Ps. I do need to run the for each and not a datatable (preferred) because of field formatting, color, formulas, etc.
Pls using a macro is a factor 6 faster but it breached our infosec policies so it is a non starter.

Hi @ton_roelandse ,

Would you be able to detail this part to make sure I understand this correctly?

  • Is the behaviour now that for the Sort Range activity, the the Excel file is opened and blocking the runtime? And is there anything prompted?
  • Do you have an Excel Process Scope activity with a setting to not open the Excel file?
  • Does this happen on other workflows?

For the second issue regarding performance, what Excel version are you comparing this to? Currently it’s on Excel 2.20.2 but what was the baseline for the faster performance?

Many thanks,

thanks for the reply - I will go back and validate the above to be current and specific as there have been a number of upgrades done in the last 2 weeks.

Hi @ton_roelandse ,

Just wanted to check in here if you managed to get more info regarding this issue and if it’s still happening.


Hi Raluca - thanks for the follow up -

I had a workaround in place to deal with this - I tried to recreate the issue and it’s not happening at the moment and the activity works as expected. So this can be closed.