Click on "Save" for a Microsoft Edge Download

I’m working within Microsoft Edge (unfortunately, the required browser) and attempting to download a file from a site. However, it doesn’t allow me to select/click on the Save or Open button in the below image because they are not a part of the webpage. Can you please help me out or provide a workaround for this?

Hi @Bhavik_Doshi,

Enable following option then it will pop up the where you need to save window then you can easily save your file anywhere by passing path

1 Like

@Bhavik_Doshi
May be this help.

1 Like

Hi @Bhavik_Doshi

Try the above ways told by @SamanGuruge and @anandji05 .

If those doesn’t work then try using Click Image Activity.

Mark as solution and like it if this helps you :slight_smile:

Happy Automation :raised_hands:

Best Regards
Er Pratik Wavhal :robot::man_technologist:t4: :computer:

2 Likes

Thank you Pratik, Saman, and Anand! I will try this on my partner’s laptop tomorrow morning and keep you updated (and mark as solution). Click Image activity did not work for me.

Try using “click activity”. Click on some Edge screen object. After that, “edit selector” - > paste the code below the image. Maybe you’ll need to change some selector name.
Captura de tela 2021-01-30 120733

<wnd app='msedge.exe' title='*' /> <ctrl role='pane' /> <ctrl name='Microsoft Edge' role='pane' /> <ctrl role='tool bar' /> <ctrl idx='1' role='grouping' /> <ctrl name='Sa*' role='push button' />

6 Likes

Hello,
here’s another thread with the solution. It leads to the selector given by @Matheuscd.

That’s it @dan.rpa .
unfortunately, this selector didn’t work every time for me. I had to change using “Recording” → “Desktop” → “click” → now I click on Edge save as button → “Save and Exit” → Now I change the selector title to “*” on Attach window.

It’s a little bit different, but I had no more troubles.

This works perfectly. Thank you so much :+1::+1:

Genious. Someone give an award to this guy, please.

create dummy drive and create a folder in that drive than in edge downlaods setting change the default location path to folder which you created in new dummy drive than disconnect the drive, Now try to downlaod the file it will prompt for save location.