Click Not Working On A Single PC

Hi there.

I have a very curious problem with running an attended bot. I have tested it and it works on different machines (one of them even is a VM) with no problems. However, on one computer, it behaves very strangely.

I have pinpointed it down to the click activity, as type into works as long as the click option is disabled. Tried simulate click, no simulate, hardware events, every property, and no difference.

One very curious thing is that once I logged into the website (this is not website exclusive by the way, this happens all around), sometimes the click activity will work, but it will click on an element that is seemingly previous to the actual element I want to click. For example, I want to click on tab 3 and tab 2 will be clicked. I want to click on element 5 of a list and element 4 will be clicked. This is strange for two reasons: 1 - the selectors are dynamic and work on other machines (only strict and fuzzy selector, no image to prevent resolution problems, etc.), 2 - when editing the selector, the selector is easily found, and I can use highlight and type into (no click) just fine.

Any ideas? For reference, I have uninstalled and reinstalled studio multiple times as well as the chrome extension and no difference was observed. Thanking you in advance!

Hello @Cesar_Pinto,

Welcome to UiPath community!

Looks like selector issue, you might have used idx or row index values. Try to get the selector from the machine where it is not working and compare with other machine selectors.

Thanks very much! Unfortunately, this is not it. Not only is the index the same, but highlight and type into activity work fine without click so that can’t be it.

Hello @Cesar_Pinto

Can you please confirm the resolution of the system is same as to the other machines? Also is there any other difference in versions which you can identify when comparing with other machines? If its working with machines and not working with one machine is strange and it can happen if the resolution is not in 100% or the hardware or software in the machine is not compatible fot the execution.


The resolution cannot be the problem since I’m only running strict and fuzzy selector, there is no image detection. This is further noticeable by the fact that the VM I’m running it in, for example, has a different resolution to my main machine and it works fine. All the versions are the same in software.

Again, the strange part is that it can recognize the elements, type into works fine, but as soon as any click activity comes up, it messes up badly.

My best guess is something to do with the “uipath_custom_id” XML termination on the page elements, but I don’t see why it would generate it wrong. I even created a process with just a click, and it simply runs but doesn’t click properly. Really baffling!

So I ended up finding the solution myself and I hope this is useful to other people experiencing the same issue. Turns out it was not the machine’s fault, sort of. Chromium API was the issue for this specific website (worked fine everywhere else) as it couldn’t input the click into the right element even when the selector was correct (hence why type into with no click and highlight activities worked). Funnily enough, Chromium API was doing it correctly on my machine and my personal VM until today when it wouldn’t work on my VM, and I decided to investigate further. Another curious thing is that Edge worked just fine on all machines so it must be some Chrome API input problem.

Here is the solution:

  • Changing not just the project, but the “Use App/Browser” activity input and any subsequent activities in that scope to “simulate” or “hardware” (I prefer simulate but you can mess about).

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.