Click image not working

uiautomation
studio
p_qa
core_activities

#1

Hello friends,
I’m developing on customer management that dosn’t work with selector, so I must use some click image active. I have this scenario: after login you must navigate to the desired function by scrolling to the end, then going up a few steps and then clicking on the image.


The problem is that when I developed the bot on the Virtual Machine I used a resolution of 1920 x 1080, while my client uses 1440x900 and instead of pointing the image click on the black circle.

When I try to grab the image again this appears to me.
image
Do you know how it is possible to solve the problem or can you suggest me other ways to solve it, for example another activity different from Click Image?
Thank you so much friends,
Camilla.


#2

@CamiCat when you use image activity make sure you develop activities with same screen resolution of production. other wise it will fail to detect.
Please change your development system resolution and create.
Hope my inputs are useful


#3

@aksh1yadav @ovi team could you please share your thoughts on the same.


#4

Hi @CamiCat,

Try this way
use launch workflow interactive activity
here you can specify the height,width and Depth of the screen

Regards,
Arivu


#5

I tried using the same PC and Virtual Machine resolution as the customer settings but it doesn’t work.
Which activities can I use instead?
Thank you so much @rkelchuri.
Camilla.


#6

Hey Camilla,

What Studio version are you using?

Thanks!


#7

I suppose it’s the same problem as in Siltra’s post: Click image fail


#8

Hello @ovi.


I’m using the 2018.1.2 version.
Can you please try helping me?
It’s quite urgent and I can’t find a proper solution :frowning:
Thank you so much.
camilla.


#9

I tried also in this way but it doesn’t work.


#10

Hi @CamiCat,
Have you tried the selector with full selector ?

Regards
Balamurugan


#11

The image doesn’t have a selector unfortunately.


All the element is seleted.
How can I do?
Thank you so much.
Camilla.


#12

Hi @CamiCat,
I don’t have similar application with me . but I tried it in my local a simple example that i below mentioned.

The above one. I try to click the administrator list. But I point it . It has the parent control that is tab. You can able to include it in the selector.

Are you able to select the table control to get the selector. like below

Regards
Balamurugan


#13

Hi @CamiCat,

I have one doubt. the image icons are dynamic or fixed one.

Regards
Balamurugan


#14






The selector is for the whole region highlighted.
I cannot manage to click on the image.
Can you kindly help me?
Thank you so much.
Camilla.


#15

Hi @CamiCat,
Already I have asked that the image icons are dynamic or fixed one.

Because if it is fixed, you can go with SendHotKeys (Tab key) .

Regards
Balamurugan.S


#16

Thank you @balupad14.
Unfortunately we can reach the icon but if I press Enter anything happens.
I have to double click on it.
How can I use Get OCR text with the text “Acquisizioni Multiple”?
Thank you so much,
Camilla. :slight_smile:


#17


Using Find Text Activity (Acquisizioni) and Double Clicking on the Uielement identified, it clicks in the black circle.
image
How can it be possible?
Thank you so much,
Camilla. :slight_smile:


#18

HI @CamiCat,
Do you have any right click menu to click the item. Because you can use the right AltGr button to use the right click of the mouse. I am looking the OCR. I will give u the feedback.

Regards
Balamurugan


#19


If I try to scrape the region with the OCR engine I get the following screenshot.
Do you know why?
Thank you so much,
Camilla.


#20

I’m just thinking outside the box here.

  • Is there a search box to search for the button so it’s the only one that will appear in that area?, then you can use keystrokes.
  • Have you tried selecting the “Incassi” button next to it and comparing the location of the click? What if it finds the image or OCR text, but the location of the click is shifted over. Then, you could try adjusting the cursor position in the properties