Click Image activity fails to find image that exists


#1

Hello,

very strange issue that I never faced before. Click Image and other Citrix activities worked well on older version (by Feb 6th, 2017). Now the activity fails to find image that exists. It simply doesn’t work in a way shown in tutorial, in its simplest form.

Same activity, created via macro recorder, works well.

Any comments?

Best regards,

V.


#2

Hi,

I’m not sure why exactly it is happening now but my assumption would be:
As you said activity fails to find the image which means there is a change in the UI Element on the screen so its unable to find UI element on the screen.So could you please "navigate to selector and “Attach Live Element” and give a try.


#3

Hi,

I tried that as well, system writes “Could not attach to live element”.

There is whole bunch of image related activities that stopped working. In this new version, released on 6th Feb 2017, lots of activities from earlier version are moved under “Compatibility” section in Activities navigation pane. I have V7 Compatibility pack installed. Activities from earlier version, build to work with UI elements, do work (e.g. mouse click on a UI element). But activities, biult for Citrix environment, don’t (e.g. Click Image, Highlight, etc.). I used them with ease in previous version, but now they don’t work.

If macro recorder is used, image is captured.

I don’t know if it will fix the issue, what I did is I reinstalled v7 compatibilty pack. I’m using community version.


#4

not sure its worked after reinstalling v7 package?
why don’t you try updating UiPath and give a try if your workflow isn’t complex one. :slight_smile:


#5

I have the most up-to-date version with all possible updates and all possible components installed. I cannot see any new updates. I have reinstalled V7 compatibility pack and no result.


#6

could you please attach you workflow?
and i believe your getting timeout error?


#7

Yes I’m getting timeout error after 30 seconds. Ok, workflow is to follow


#8

This is not good if it is confirmed. What version are you on now? And what was the previous version.


#9

Hi,

I have uploaded the most simple workflow - click on antivirus icon. It throws timeout error.

Previously I used Version: 2016.2.6204

Now I use Version: 2016.2.6246

Windows 10

Image test.xaml (22.8 KB)


#10

Please update…there were some issues fixed in the next updates: https://www.uipath.com/release-notes/uipath-v2016.2.6274


#11

Thank you.

I would like to but I cannot see this newer version in my “Manage Packages” windows.

Shall I just uninstall the system and download Community version again? Shall I retain the license?


#12

Start->Help->Update


#13

I did what you say but there is no update command here.

I’m attaching screenshots


#14

If you click Stable… ?


#15

I always used Stable. So now I clicked it again and restarted the system. No new packages appeared.


#16

Ok. Click Stable and restart. If it does not work @qateam will check and I’ll send a download link in private.


#17

Thank you. I tried as you suggested, but unfortunately it doesn’t work.

I really appreciate your support.

Best regards,

V.


#18

ok. @qateam will check why the download link does not appear. Try the link I have sent in private.


#19

Thank you. I’ll let you know.


#20

Citrix related activities started to work in version 2017.1.6309

THANK YOU