"Click" don't work with RDP connection

I would need to get over this screen triggered when I try to make Remote Desktop Protocol connection… by clicking Yes or No or anything else. It doesn’t allowed any UiPath activity since the UiPath Runtime installed on Remote Machine is not loaded yet.
Any idea how to get over?

use cv screenscope activity


Use CV click activity to get it done…

We have to provide the API key if we wants to use the CV. Which will get it from orchestrator itself…



@THIRU_NANI : where do I need to add those Keys ? In Studio or ? I already have them in Orchestrator, as in your screenshot.

@Sree_Krishnan_vellinezhi : good point, thanks, I start to explore that path… I too focus to build on UiPath Runtime.


you need to generate in orchestrator and need to copy that key.

come to studio and use the cv scope inside that use cv click… in the cv scope properties you have to paste the api key with in the double quotes


@THIRU_NANI : got it, meanwhile. :slight_smile: I’ll try to see if solves the problem then I’ll update here.

Users shouldn’t be logging into servers that run automations. This is your problem. Or you need more RDP licenses on that server. Or you have your robot set to console login, which you shouldn’t.

@THIRU_NANI : all looks executed in the workflow… still that Yes button is not clicked in reality, only in the workflow.

Second day update:
strange enough, but never got same result - green lights, but only errror “not found element”.

@postwick : if a human can do it, then my robot have to. :slight_smile:
I’m aware about that multiple RDP licenses scenario but I’m looking for this simple one.


Is it throwing any error?


@THIRU_NANI : no error, only success as green light shows in the screenshot.


Second day update:
never got same result - green lights, but only errror “not found element”.


Dubug it and check whether it is clicking on YES or Not?

If yes try to add some delay and try again



Check whether if you can bypass this user alert by editing some configuration in the RDP file or connection settings.


@Nithinkrishna : tried but there is only the brutal scenario to just sign-in and kick-out the already working / logged in user - which is not what I’m looking for.

1 Like

But you’re using UiPath wrong if users can step on its ability to open RDP sessions.

Having appropriate licenses, and not letting users remote into automation servers, is the simple one.

Okay got it then.

@postwick : not at all, Paul, since on the Remote Machine the logged user is asked by default (RDProtocol) if accept that connection or not (if no answer in 30 seconds, the connection is dissmised by default). It’s not simple kicking off that user.

That’s not the point. You’re causing yourself this difficulty of having to deal with this prompt because of one or more of:

  • you don’t have enough RDP licenses
  • you have the robot set to console login
  • users are using servers that Orchestrator uses

@postwick : got your point, thanks! I still want to see if I can go through it with some help from UiPath community.