Click Button Not Recognized

I created a robot to run through a series of screens in a program. At the bottom of each screen, it clicks a “Continue” button. This has been working fine for each screen until last Friday. Now it clicks Continue on each screen except one of them. The weird thing is that it skips the step and moves on as if it did select it in UIPath.

Click activity - Selector Editor:

Things I have tried with no success:

  • Checked SimulateClick
  • Unchecked SimulateClick
  • Deleted it and added a new Click.
  • Recorded my steps, but it still doesn’t select it. I opened a blank UIPath and record the same steps, it worked. I tried copying those steps over to the desired UIPath with no success.
  • Looked at it in UI Explorer and used the same selectors.
  • Removed the idx=‘1’
  • Next to the Continue button is a Cancel button. I used the same Click activity and changed it to select Cancel and it worked. Changed it back to Continue and nothing.
  • Copied one of the other Continue activities and tried to use it again.
  • Closed all windows and restarted.

Any help is appreciated. Thank you.

1.You can try to use aaname property in selector
2.Use anchor for click activity
3.Use Element exist for next screen if that gives you false then loop it to click again on that button
4.Click Text can also try
5.Use Image Automation(Try this at the end if all efforts are not helped), it will definitely work for u but problems will arise if in future that image changes on that application or on site