Selector error while clicking a Button

Hi Everyone,

While using click activity there is a button.

Click works fine for almost all cases and selector is validating.
But for few cases same button is not validating selector.
Already tried , delay, retry , click image , click text.
Not working, but Selector is same for that button.

Can anyone suggest some good solution on this .
Note : Hotkeys are working, but we are trying to find different solution where keyboard is not needed.

Hi @Sahil_Garg1

Try defining an achor as well. In modern activities you can define anchor while selecting the click button.

Hi @Sahil_Garg1

Have you tried with Click image activity? If not just give a try


Tried man, but not sure why click is not working

already tried

Can you share the image of the button along with that share the selector also?


Selector :

Did you try with all possible values in “Input Mode”?


1 Like

Hi @Sahil_Garg1

Use SendWindowMessages as an input method.


1 Like

What was the error while running the process? Why are you not try with Send Hotkey?

Hot keys is not sutable option, becoz we have to press 4 tabs and enter and somtimes 5 tabs, logic can be made but too complex for large cases.

lemme try above two input methods .

Not sure, both not working, it is an windows application basically and only in 2 percent cases not working.

Is there anything else that could be different in those cases? For example, a different layout of the page, the visibility of the button, a little delay in the loading of the screen, etc…? When it doesn’t work, do you get an errror message? If not done, can you set “Continue on error” to False to check whether there’s an error message?


Basically, not able to find ui element

Can you try to create a new Click activity (just temporarily, for the sake of troubleshooting) and configure it so that it clicks on the button on the cases that are failing? This will allow to check whether for some reason UiPath suggests a different selector for those specific cases, and if so we can investigate further on how to fix the situation.

its new only , in test sequence