Click activity not ending when simulate click is checked

Good morning,

I am fairly new to UiPath/RPA, and have had success in developing processes that will run attended. Currently, I am transitioning a process that was created as attended into an unattended process. I have begun by converting all the click events into simulated events and have had success in all but one.

All the clicks are basically doing the same thing; they click on a desktop application text. If the text is a link, there is a pop up with a question. The bot clicks yes on this and moves on to the next transaction.

On one of these click events I have tried both SendWindowMessages and SimulateClick and neither one works for simulating this event. The process steps into the activity, it clicks and the popup appears. The process does not continue until the popup is closed. I have similar events in other parts of the process, but this is the only one that I have not been able to switch to run in the background. the stranger thing is that it will not timeout, not by default nor when I set it for a specific time. For now I have left it to run in the foreground since it does both move on in the code and expire if you set the time out.

I would appreciate if you could help me figure this out.
Thank you for your time,

1 Like

Hi @JLO

Sorry but the issue not to clear ? Do you want your bot running in background is that make sense ?

cheers :smiley:

Happy learning :smiley:

yes. I have started to change the click events to run in the background, but one of the clicks does not exit the activity when I change it to simulate click.

1 Like

Hi @JLO

Yes thats right you can use Send Window Messages or Simulate Click in the background
Lets try to Set the Wait For Ready to None

cheers :smiley:

Happy learning :smiley:

@JLO This is just my opinion, setting 'NONE" for wait for ready would not be a good practice as you are clicking on ‘href’ hyperlinks which take their own sweet time to load.

Keep it interactive at least, also try using the default click only for this. (Try passing the click activity in parallel to handling the popup that comes up with the hyperlink click)

Also, the BOT should not wait forever as TimeOutMS property default is only 30000 ms. Check these out if it doesn’t work you can sen a click event using ‘inject javascript’.

Hope this helps :slight_smile:

1 Like

Hi @JLO

I do agree on the point mentioned by @Raghavendraprasad. Make sure those points are addressed as mentioned. Additionally, I would like to know whether this pop up that’s not working, is it just a message box or a separate window?

@Raghavendraprasad
I have changed the properties several times trying to address the issue, but I will review to make sure I address the ones you have listed.
I am not yet familiar with running activities in parallel. I will do some more research and to see if I can resolve it this way.

@Lahiru.Fernando
It is just a message box. I thought that maybe the button click is supposed to return a value, but other click events do not behave like this. I will review with @Raghavendraprasad has suggested and will get back to you.

Thank you for your time.

1 Like