Citrix Automation Clipboard Not Working

excel
citrix

#1

Hi,
I have one windows application in citrix in that there is one grid and grid have functionality to export data into clipboard.
I tried this think in UiPath using clipboard but I din’t get any value from clipboard in UiPath.

Please help me to sort out this problem or any other solutions.

Thanks,
Sandip Nighot


#2

Hi Sandy,

Does it work for you manually (as in, after exporting to clipboard can you paste it to f.e. Notepad with ctrl+v)? Some Citrix/RDP connections have blocked clipboard sharing.

Are you using GetFromClipboard activity or trying to just paste?

Regards.


#3

Yes @andrzej.kniola its working manually perfect.
I have automate till export data into clipboard.
below steps I have atutomated
Step 1 : Click on Export to Clipboard button (now I have data in clipboard)
Step 2 : GetFromClipboard (output store in Datatable)
Step 3 : here checking data if datatbale


#4

Ok, in that case one of these should work:

  1. Paste using SendHotkey ctrl+v to the target field/app.
  2. Get data using GetFromClipboard activity. Depending on what’s the exported content, you might be able to either work on it directly (maybe with some parsing) or you’ll need to first f.e. paste it to Excel (if it’s an exported Excel content).

#5

Didn’t see the edit.

Is the Output really in DataTable format? It might be that it tries to store it into that type, but can’t. If you try to store into String, does it work?


#6

No in string also I don’t get value
@andrzej.kniola can you please tell me how can I achieve below steps in code

  1. Click on Ok button - (result copy to clipboard) here I used click Image – manually working perefect
  2. Get data using GetFromClipboard – (here I crateed datatable variable and set output of clipboard as a datatable variable)
  3. Checking here databable —(but value is null)
    Plz help me where I am missing things

#7

What happens if you use CTRL+V in a local notepad file (using UiPath). Are the results pasted?


#8

Hi @andrzej.kniola

Can u plz tell me how I can set target filed/app using SendHotekey(Ctrl+V) or any example.


#9

Hi,

Just use the SendHotkey activity and give it a proper selector (same way as you’d give to a TypeInto or Click activity).


#10

Thanks for reply … I got the issue this is due to large data that’s why I am not able to check in String variable. I check with small data now its working.
But I have large data in grid and I want paste data into excel and want to perform logic over.
Any idea how I can go ahead.

Thanks,
Sandy


#11

Hi @Sandy ,
u got any solution for it?


#12

I had a similar problem, coping from Citrix, I was trying to paste into Excel.

I tried first to use the clipboard element, but when pasting into Excel it was pasting an XML code. It was pasting okay in notepad. In the end I used Ctrl+V inside Excel application element