Checkbox with Error HRESULT E_FAIL has been returned from a call to a COM component

Does anyone have a workaround for this error in chrome? it is a known issue, UiPath is aware of the issue but there is no timeline of when it will be fixed.

I am trying to check if the checkbox is ticked, the get attribute activity gives the aforementioned error. I tried find children,get text, get visable text but the way checkbox is written makes it impossible:

label title=“false” id=“consentsList|1@isSelectedLabel” for=“consentsList|1@isSelected” uipath_custom_id=“6”></label

I have tested in internet explorer and get attribute works, is there any way I can avoid rewriting the whole process in IE?

1 Like

@DVM can you verify your selector. the red box from screenshot is not surrounding the checkbox. Feel free to post the selector here for us

That’s because I was trying to use find children at that point to find the checkbox uielement.

Could you also try to indicate the checkbox as your element for the get attribute and see whether it works

1 Like

Tried it. Gives the error in the title for chrome but works for IE

@DVM, if you are using Find Children activity and in between page DOM structure is modified then UiPath will throw an error.

Instead you can have a local array or list of all IDs (or any other unique reference) of all check boxes that are to be checked. And then loop through this collection to generate a dynamic selector and use check activity.

The issue is that Find children does not return anything unique I can use, as I mentioned above the checkbox is written in a weird way

Is it possible for you to check the checkbox and then use “Find Children” activity to look for any variance in the property value?

Tried it, gives me the exact same three values as when it is unchecked(the same as on the screenshot)


Please can you share the selector of this checkbox?

If possible, share all the attributes with the help of UiExplorer tool.

Don’t think the selector is the issue here, as mentioned “Get Attribute” works perfectly in IE but there is a bug in chrome that gives this error.

The attribute that I am trying to find as a workaround for “Get Attribute” not working in chrome is highlighted in red, but UiPath is not able to match it in the UiExpolorer


Have you tried using “checked” attribute? It’s default one and should work.

that is the on that gives Error HRESULT E_FAIL has been returned from a call to a COM component in chrome, but it works fine in IE

I’m still curious to see the selector of exact “GetAttribute” activity you used.

Othewise, can you please try to use below simple selector for “GetAttribute” activity and check the value of “checked”?
webctrl id=“consentsList|1@isSelected” type=“checkbox”

Check is this one helps

Here is the selector:

webctrl id=‘consentsList|1@isSelectedLabel’ tag=‘LABEL’

When I try "GetAttribute” is when I get the error.

The checkbox is not defined as the type checkbox and the only thing UiExplorer can match is the label

As I said I get the error in chrome and it is the whole reason I am writing here

@DVM here we do see that the children filter is failing
Check the selector and if its not a direct child then change find children property scope to FIND_DESCENDANTS

I would suggest to retrieve the selector to the check box via uiexplorer, manually navigating in the Visual tree and right click set as target element

It seems to me that problem comes from wrong check box selector and not from a chrome bug. Another option to test is to do a click activity in a separate xaml to the check box (alternate type into space to the checkbox)

Tried FIND_DESCENDANTS gives the same 3 elements as shown in the screenshot.

As mentioned before the same selector works like a charm in IE, if you click the link in the description it shows a thread where uipath officially responds that they are aware of the issue and that there is no timeline on when it will be fixed.

I came up with a workaround using chrome dev tool where I copy the selector from the dev tool and do regex on “title” value. so far works like a charm, if you guys have any feedback I would of course appreciate it.

chrome dev tool.xaml (15.2 KB)