Checkbox not being recognized as checkbox

I am building a robot to do updates to a system and as such i need to check if the checkbox is checked. I tried using the get attribute function but it was always returning false. After some investigating I realized that the selector did not include a “checked” selector

image

I have also tried using the image exists attribute but it has proved to be inaccurate in this case

edit:

I am currently dealing with the higher checkbox in this picture

image

Hi @omari_lawrence,

A screenshot of the checkbox would also be helpful to troubleshoot. Also, I think you could use the UiPath.Core.Activities.Check activity. Via this activity, you can specify how the element should Act.

image

But if you are not able to find the check element at all, It might be hidden so you have to traverse the UI Tree in the UiExplorer window to find the correct selectors.

I have included an image of the checkbox that i am working with.

Also upon attempting to use this check activity i got the following error:
“Check ‘TwwCheckBox’: Attribute not supported by the current UiNode.”

One of those elements, I feel your frustration!

Ok, could you try if clicking on the “Place of Buisness” text box and then sending Hot keys - Tab * 2
You can send hot key twice by using
For each i in Enumerable.Range(1,3) (i type argument here is int)
Do : Send HotKey -> Tab

After the for loop Send HotKey --> Enter (Trying to check the box)

I ended up in PEP First Name

Oops, my bad. I am used to Python. In .net Enumerable.Range(1,3) will perform the action three times. In other words, 3 is included in the count.
Try with Enumerable.Range(1,2)

Debugging like this is like shooting in the dark. Never can test it myself :slight_smile:

No changes the enter hotkey does not appear to have any affect on the checkboxes

If there are no other proper selectors sending hotkeys may be the savior.
I am sure there is a way to get it done this way, but you have to manually check which hotkey works. Manually, tab upto the checkbox and try which keyboard key activates the check box.
Then just substitute “Tab” with the key which worked. Start next with “Space”.

To uncheck: Space again and after that a Tab

Keyboard shortcuts in Windows (microsoft.com)

Hope this helps!

okay thank you very much, though i realize we may have strayed from attempting to prevent double ticking the checkbox, i appreciate the time you have spent assisting me.

Great you fixed it!
Noted that double clicking is another option :+1: