Error Code: Error HRESULT E_FAIL has been returned from a call to a COM component


Getting this error while using Get Full Text and Click Activity. I did not get this error last week. The bot functioned as intended. This is a recent issue.

Steps to reproduce:

Current Behavior:

Getting the above error.

Expected Behavior:

Should get full text from a table and right click on a file in SharePoint.

Studio/Robot/Orchestrator Version:

Last stable behavior:
Last stable version:
OS Version:
Others if Relevant: (workflow, logs, .net version, service pack, etc):
No helpful post were found on forums here.


Hi @Geek,

Could you please share how did you resolve it?

I actually pulled every Activity out of “Attach Window” and it worked. Not sure if this was really something I did, rather different activities wouldn’t behave properly with each other. I still think this needs to be resolved or at least have a clearer error explanation then just “Error HRESULT E_FAIL has been returned from a call to a COM component”, which is not very helpful and confusing.

You’re right, it’s not an explicit error message. I will pass this to QA team so they will check if the error message needs to be changed.

Thank you for the feedback!

1 Like


I have same error.


I restart and reinstall several times UiPath and Browser’s extensions.

The last that I did before crash was update Visual Studio.

My VS version is 15.4.5 and .Net version 4.7.02046

I hope that this can help to find error.

Best regards

Apologies for a late response. My team has experienced this error on multiple occasions and all are random occurrences. Did you solve this? Can’t say I have a solution for you. You’ll just have to disable/enable pieces until you figure out the problem. Best of luck!

I am getting same error when I try to click on the data in Filpkart for data scrapping, Is there any solution for this? Please help me.

Thanks in advance :slight_smile:

Hi sumitra,

What browser are you using? Please try to remove the extension and then add it, restart Studio, restart the browser and try again.

Let me know if it worked.

Hi @ovi,

I am facing same problem with IE11 browser , I am trying to use Find children activity… pls help

Give us more details please, maybe a workflow too so that we can try to reproduce

I’m experiencing this kind of issue too! Cant’ use UIPath because of that


@Gabriel_Tatu has this error been fixed yet?
My team is experiencing the error when we try to utilize a Window variable (in Attach Window) that is returned from Invoking another workflow and then perform any activity that uses the “partial selector” inside the Attach scope.

Our workaround is to use the selector instead of window variable.

Attached is a reproduction of the error, where MainTest invokes WindowTest then uses the window variable.
MainTest.xaml (9.4 KB)
WindowTest.xaml (6.3 KB)


1 Like

Let me try the workflow you ve sent first

Ok, this is what i suspected, we were aware of this issue, but i can`t provide a timeline for when we will fix it.

1 Like

Did you get a solution to this problem?

Do we have a resolution for this? Update please. thank you

I had a similar issue and the issue was with .Net Framework version.

I have uninstalled and installed .Net framework version 4.6.2 and the problem was resolved

any resolution to this yet?