Can't use "Type Into" to work in search field

Hello, I am trying to write text into the search bar on the page “” and nothing happens. the search bar expands and the program ends without throwing an error. I can’t understand what is going on. It works for other similar sites like eBay with a field one must type into. Is there anything I can do to get this to work better? I’ve even attempted using a separate click event to expand the search bar, and then a second to type into said expanded search bar.

Try the option to “click before type”.

–make sure that you have these properties enabled in the property panel of TYPE INTO
EmptyField - enabled
ClickBeforeTyping- enabled
Simulate Type - enabled
WaitForReady - Complete

Send window message - enabled only if any hot key is used along the string and if so disable the simulate type property

Kindly try this and let know for any queries or clarification
Cheers @N4V3N3114

I’ve tried to do those things, but UiPath still did not type into the text field. It works on other websites so could it just be a problem with that one search bar?

is that search bar chosen as a element or a image
if not try with send hot key activity with key as tab that will take us to that field
once after that we can use TYPE INTO ACTIVITY with the input string without any selectors
its more like using only keyboard to navigate to a field and typing without using mouse

Cheers @N4V3N3114

problem resolved check this (24.1 KB)

1 Like

I can’t figure out what you did differently. It looks like something I had tried but this works perfectly. Thank you very much for this

Okay I figured it out (at least I think) I needed to move the activities out of the “Attach Browser” activity, and instead move the “Click” and “Type” events under the “Open Browser” event. I suppose that seems kinda obvious but the “Attach Browser” event always got added outside of it. Thank you again for your help!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.