Type into activity not working on a Search box

I am using type into activity on a search box on a website (https://www.taste.com.au/) for practice purpose. It works when Search box is visible on screen. FYI, i tried with all the input methods and also tried ClickBeforeType. Any help will be appriciated.Thanks!

Hi @nohow04

Instead of using the Type into activity use the Set Text activity which allows to paste the text in the Search box.

Check the below image for better understanding,

Hope it helps!!

Thanks for your quick response, I tried, Not typing anything. Can you please check from your side? I have already provided the URL.

I don’t have any issue with this activity on this site. Which browser are you use?
Can you share your workflow?

Hi, I am using EDGE Browser. It is not throwing any error , but also not typing anything. Also about WF, I have created new sequence with just TYPE Into activity.

have you enabled UiPath extension of edge browser?

Hi @nohow04

Can you try set focus activity

Before Type Into Activity , Use Set Focus activity

Input methods - SimulateType/ SendWindowMessages

Hi Neha, Yes, it is enabled.

I’m using also edge and this activity works without any issue.

which version of Studio and activity package do you have?

studio version and activity package is - 2023.10.2

Is the issue because of an advertise on the Browser?

Okay @nohow04

For me it’s working. When you are indicating the element check the strict selector and uncheck the fuzzy and image. After that Open the properties of Type into activity and expand the Target option.

In the visibility check dropdown select the Fully visible.
In the Wait for page load option select the Complete.

Check the below image for better understanding on properties,

Hope it helps!!

okay, please check once browser extension in edge. actually, I’m also facing same issue and after enabling extension type into activity work.

Or else you can try modern activities

check below workflow
recipe.zip (8.2 KB)

I tried the steps you suggested. I am getting this error

HI Neha, I downloaded and executed your workflow, not working. Nothing is typed in search box.

Hi @nohow04

It’s working fine for me as well after using both Classic and Modern activities
can you once try with the below xaml and let me know it’s working out for you or not !

Make Sure you have extension for the browser you’r using and instead of doing step into, Use break point after type into activity and then check it

Main.xaml (20.4 KB)

Hi Vinitha, I tried. Still no input in the search box.

okay @nohow04 Can you once restart the studio and your system

Hi @nohow04

I have tried on Edge Browser & its working fine for me

Try below code
Test.zip (1.7 KB)

Hope it will helps you :slight_smile: