Can't indicate local Ruleconfig.json in uipath.policies.config


As mentioned in Governance page, I tried to use RuleConfig.json file on local machine by indicating in uipath.policies.config file.
I wrote the “Analyzer” section as follows;

"Analyzer": {
  "AllowEdit": true,
  "ReferencedRulesConfigFile": "C:\\Users\\Path\\to\\RuleConfig.json",
  "EmbeddedRulesConfig": null

but it seems my custom rule sets are not applied.

I know that if I locate RuleConfig.json file in "%LocalAppData%\UiPath\Rules", the rules are applied. My question is how can I indicate in uipath.policies.config file.

Hello @shunsuke.fujisawa!

It seems that you have trouble getting an answer to your question in the first 24 hours.
Let us give you a few hints and helpful links.

First, make sure you browsed through our Forum FAQ Beginner’s Guide. It will teach you what should be included in your topic.

You can check out some of our resources directly, see below:

  1. Always search first. It is the best way to quickly find your answer. Check out the image icon for that.
    Clicking the options button will let you set more specific topic search filters, i.e. only the ones with a solution.

  2. Topic that contains most common solutions with example project files can be found here.

  3. Read our official documentation where you can find a lot of information and instructions about each of our products:

  4. Watch the videos on our official YouTube channel for more visual tutorials.

  5. Meet us and our users on our Community Slack and ask your question there.

Hopefully this will let you easily find the solution/information you need. Once you have it, we would be happy if you could share your findings here and mark it as a solution. This will help other users find it in the future.

Thank you for helping us build our UiPath Community!

Cheers from your friendly

Hello, I have the same problem.

Hi @shunsuke.fujisawa @KarineC,

Have you tried doing it without the use of governance file? Does it work that way?

Just updating custom rules in ruleconfig.json file and seeing if custom rules are visible in workflow analyzer settings window?

Also, have a look at below documentation, process is little different to have custom rules enabled in studio.

Link as below:

Let me know if this helps.


Hi @sonaliaggarwal47,
If i disconnect my Studio to the Governance File and if i change some level of one rule in my RuleConfig.json, the change doesn’t apply in Studio. When i reopen my RuleConfig file it had changed with the last value (some cache system maybe…).
I don’t need custom rules so I haven’t tried it.
Il think i will use the “EmbeddedRulesConfig” attribute in the Governance File even if it’s not the best solution…

Hi @KarineC,

When you apply any change in rule in ruleconfig.json file, please note that post this, studio restart is required for changes to take effect.

And when you make any changes in rule directly from studio, it is immediately reflected in ruleconfig.json file.

Also, please note that even if any or none of the rules are defined under EmbeddedRulesConfig attribute, still governance will be enabled for all rules per ruleconfig.json file. So defining default rules there is not mandatory, this is specifically for defining custom rules.

Hope this info helps.


1 Like