Can't get to Exchange shared mailbox folders

Hi Community,

I’ve updated UiPath.Mail.Activities to version 1.2.6863.29868 but there is still a problem with getting emails from shared mailbox folder other than Inbox using Exchange Get Mail activity. However the release notes states that it was fixed…

No matter the syntax of the folder name it throws an error “folder not found”. It returns emails without a problem when folder is set to “Inbox” only. I’ve tried "mailbox@domain.com/Inbox/folder name" and “Inbox/folder name” and “/Inbox/folder name” no luck

Please help, is there any other way to get mails from such a folder using exchange?

Did you try with another folder at the same level, not inbox/folder?
How do you check that the target folder really exists? Do you see it in Exchange Owa for that shared account?

Hi Gabriel, I can’t read any other folder than “Inbox”. I can see the folder structure using OWA.

Also I was able to read all the folder names and their Folder ID’s from the shared mailbox using Exchange Application Scope and FindFolders method of the ExchangeService object. The folder is there.

understood, i will investigate further and come back

can you try inbox\folder ? :slight_smile:

Still the same… :frowning: I’ve tried “Inbox\folder” and “inbox\folder”. However “Inbox” and “inbox” works fine… it looks like it’s case insensitive

Its working fine for me, just tested with exchange 2013 and 2016. There s something that we re missing…

1 Like

Do you have Outlook installed to add your user? Then you can properly check the folders of the shared account, delete or create new ones.

Yes, I’ve tried it with outlook. It works fine. I can reach all the folders from the shared mailbox, but the robot should be used without outlook. I need to figure out how.

Outlook uses short name of the shared mail account and translated (localized) well known folder names. I’ve tried those names in Exchange activity but no luck.

Just do a test, create a new folder in outlook for the shared account and try with that one, maybe there is a difference in how the folders are created without outlook. I will try to check the exchange config page to see if i can create folders from its interface.

The newly cerated folder is also unaccesible. I’ve created it in the root of the shared mailbox on the same level as “inbox” and inside the inbox. I can’t access it any way providing it’s name as a folder name in exchange activity.

Strange thing that there is no actual “Inbox” folder with the explicit name in the shared mailbox folders list but it points to the actual inbox. In outlook activity I need to refer to it using original language. Also Exchange FindFolders method returns no “Inbox” folder but the localized name.

I am having the same issues. I can access basic folders, and they appear only in English:
Inbox (not case sensitive)
Sent Items (case sensitive)
Archive (case sensitive)

But if I create a new folder in outlook or through OWA I am not able to read those folders.

What can be the solution to this?

I’m also having the same issue. Can read the Inbox of the shared mailbox but not the subfolders in fact regardless of the subfolder path it seems to read the Inbox". Have tried setting “Reviewer” permissions on the subfolders but to no avail. Any help would be appreciated. Need to use Robot without Outlook so need to used Exchange activities.

Hi Everyone,

I’m still trying to figure this but here are some more facts.

Sorry for the description but I’m not an expert :slight_smile:
There may be different types of shared mailboxes configurations. I have couple of different shared mailboxes and some of them are working fine with exchange activities, and some of them are not.

If you have an outlook you can figure out which will work but I still don’t know what is the issue.

When you can add the shared mailbox as a separate account to outlook (as a separate account with separate data file not via the personal account shared mailboxes option!) and then the mailbox works (you can see folders and items and it opens normally) you WON’T be able to access the folders through exchange activities. Those activities will only reach WellKnownFolderNames such as “Inbox” etc.

When you add the shared mailbox to outlook as a separate account and you can’t open it (but is still possible to add them via the personal inbox account and then they work fine) then they will work fine with exchange activities. You can use the actual folder names and paths.

Has anyone found a solution for this problem?

I’m working on a similar case were I want to move an email to a folder in a shared mailbox, but the robot is unable to find this folder. (while a folder like ‘Inbox is no problem’ )

In my case we actually didn’t find a working solution. The workaround was to use Outlook client which works fine but it’s not an elegant solution and not applicable everytime. There were some promising effects because some shared mailboxes were able to reach actual folder names instead of WellKnownFolderNames (like “Inbox”) but it’s still not resolved.

The recent update of Mail Activities Pack 1.3.0 didn’t resolve the issue. Come on this is not a single issue. A lot of people are reporting this… :frowning:

Hi @Sparrow

I had a chat about it internally and the activity pack is tested for Shared Mailboxes that were created using the Exchange interface.
As such, the newest release 1.3.0 was tested to be working in this exact scenario.

Is this the case for you (as to the way the Shared Mailbox was created)?

Thanks for the anwer. Unfortunatelly version 1.3 hasn’t change much in my case. Still the activity is not able to reach folder names in shared mailboxes, using their own folder names/paths. It can only reach the folder names when using well known folder names.

I have no idea about the interface which created those shared mailboxes, but they are used using the exchange 2016 api/outlook

Hi
Was there any solution to this? I’m also struggling to get mail from shared mailbox.

Thanks,
Scott