How to get outlook emails from a shared folder (not a subfolder of inbox)

Hi all,

i have recently a question to get all the outlook emails from a shared folder. The shared folder is not under inbox. I tried to use the path of the folder (\Public folder -\all public folder\1 companyx\incoming invoices) in the proporty panel-> input → MailFolder. But it always returns “The specific folder does not exist”


Does anyone has an idea how to fix the problem? I’d really appreciate your help a lot!!!


I’ve only had luck accessing a shared mailbox with the get exchange mail message activity. The exchange mail message activity has a shared mailbox property that when given the email address for the shared mailbox I wish to retrieve the emails from and the desired folder, along with the other required properties, works for my needs. You might give exchange mail activities a look to see if they would work for your needs.


Hi Tyler, thanks for you reply. One follow-up question. What properties do i need to set for get exchange mail message activity? It’d be really nice of you if you could send a screenshot.

That should get you going in the right direction. If you have a specific question about any of the properties I can try to help!



You post had helped me as well! Thanks a lot!

But I have a problem with the shared mail box.

If I use “Inbox” in the “MailFolder” property, the Emails will be retreived from the shared mailbox.
However, if I use other folder names, which are existing folders at the same level as “Inbox”, then the “Get Exchange …” activity will give me an error saying the folder doesn’t exist.

Since the shared mailbox and my main account co-exist, if the folder happen to have the same name as one of my main account folders, for instance both of them have a folder called “Archive”, then even if I put the shared mailbox Email address in the “SharedMailbox” properly, this activity still pulls Email from my main account.

Does it also happen to you?



1 Like

@hellitonwoo The same thing is happening here. Did you find any solution?

Guys, I got the solution from UiPath. It’s very simple. Please make sure your packages folder has UiPath.Mail.Activities.1.2.6768.21383-alpha.nupkg(Mail activity latest version of alpha release)

Hey Tyler ,
Thanks for your valuable input .
server details you have left empty , will it work without providing the server details

Raj kumar

Hi, could you please post a link for this package so I can download it… Thank you very much!

Hi how could I download the latest version of UiPath.Mail.Activities?


Hi Viktoria,

you can find the guide at this link: Managing Activities Packages

1 Like

Hi thanks but I can just see version 1.1.6562 as the latest not 1.2.6768 as were mentioned above

Regards Viktoria

Hi @miketong44, did you ever figure this out? I am trying to accomplish the same thing using the Get Exchange Mail Message activity.


I had problems in UiPath Studio 2018.3 but when I tried this in Studio 2018.2.6 it works. @meganlord what version of studio do you use?
Best Regards

@viktoria, I am trying it on 2018.4.

It is entirely possible that it is user error! I have a more experienced coworker coming to help me with it this afternoon.

Hi did you get it to work?


Hi Viktoria, I did not.

Ok do you get any error or what happens?


@viktoria , the department I was working with ended up switching from Public Folders to a Shared Inbox, so I did not pursue it, and this ‘solved’ my problem.

Using Get outlook mail message activity
Account will be “Public Folders - imran.khan@XXXX.XXX”, which is your username with public folders and a hypen in the front
MailFOlder will be “All Public Folders\Test Folder1”, which is the location of the folder.