Can't find most of the packages

studio
package

#1

Hi,

I googled around looking for information, but couldn’t really find answers. I installed UIPath Studio Community v2017.1.6309 (on Windows 7 Pro 64bit) and I can’t see most of the packages in the “Manage Packages” screen.

When I open the package manager, I can only see “UiPath.Core.Activities” and I am looking for some of the REST/WebAPI packages… I deleted the temp folders under “Packages” and “nuGet” but couldn’t make it work. Is there another package source I should use?

Please advise… thanks@


#2

Hi,
I hope your using latest version.
alternative ways.
1.repair or uninstall and try to install again (most of the time it works).
2.you can add nuget package manually by navigating ->manage package->right click on left tab and click on “configure sources” and browse nuget package from local which you intended to add.

Regards,
Dilip


#3

https://www.uipath.com/guides/managing-packages


#4

I checked this link before… the other packages do not show up there… :S


#5

I am looking for the “standard” packages, nothing custom or special.

I currently see only UiPath.Core.Activities… that’s all…

Is this because I am using the Community version?


#6

Even your packages folder has only that Nuget? If so, did you try reinstalling?


#7

I found this exception in the log

10:47:50:964 => [WARNING] [Orc.NuGetExplorer.PackageQueryService] [5] [WebException] System.Net.WebException: The underlying connection was closed: An unexpected error occurred on a receive. —> System.IO.IOException: Unable to read data from the transport connection: An existing connection was forcibly closed by the remote host. —> System.Net.Sockets.SocketException: An existing connection was forcibly closed by the remote host
at System.Net.Sockets.Socket.Receive(Byte[] buffer, Int32 offset, Int32 size, SocketFlags socketFlags)
at System.Net.Sockets.NetworkStream.Read(Byte[] buffer, Int32 offset, Int32 size)
— End of inner exception stack trace —
at System.Net.Sockets.NetworkStream.Read(Byte[] buffer, Int32 offset, Int32 size)
at System.Net.FixedSizeReader.ReadPacket(Byte[] buffer, Int32 offset, Int32 count)
at System.Net.Security._SslStream.StartFrameBody(Int32 readBytes, Byte[] buffer, Int32 offset, Int32 count, AsyncProtocolRequest asyncRequest)
at System.Net.Security._SslStream.StartFrameHeader(Byte[] buffer, Int32 offset, Int32 count, AsyncProtocolRequest asyncRequest)
at System.Net.Security._SslStream.StartReading(Byte[] buffer, Int32 offset, Int32 count, AsyncProtocolRequest asyncRequest)
at System.Net.Security._SslStream.ProcessRead(Byte[] buffer, Int32 offset, Int32 count, AsyncProtocolRequest asyncRequest)
at System.Net.TlsStream.Read(Byte[] buffer, Int32 offset, Int32 size)
at System.Net.PooledStream.Read(Byte[] buffer, Int32 offset, Int32 size)
at System.Net.Connection.SyncRead(HttpWebRequest request, Boolean userRetrievedStream, Boolean probeRead)
— End of inner exception stack trace —
at System.Net.HttpWebRequest.GetResponse()
at NuGet.RequestHelper.GetResponse()
at NuGet.HttpClient.GetResponse()
at NuGet.RedirectedHttpClient.GetResponseUri(HttpClient client)
at NuGet.RedirectedHttpClient.EnsureClient()
at System.Lazy1.CreateValue() at System.Lazy1.LazyInitValue()
at System.Lazy1.get_Value() at NuGet.MemoryCache.GetOrAdd[T](Object cacheKey, Func1 factory, TimeSpan expiration, Boolean absoluteExpiration)
at NuGet.RedirectedHttpClient.get_CachedClient()
at NuGet.RedirectedHttpClient.get_Uri()
at NuGet.DataServicePackageRepository.get_Context()
at NuGet.DataServicePackageRepository.GetPackages()
at Orc.NuGetExplorer.PackageRepositoryExtensions.BuildQueryForSingleVersion(IPackageRepository packageRepository, String[] filters, Boolean allowPrereleaseVersions)
at Orc.NuGetExplorer.PackageRepositoryExtensions.FindFiltered(IPackageRepository packageRepository, String[] filters, Boolean allowPrereleaseVersions, Int32 skip, Int32 take)
at Orc.NuGetExplorer.PackageQueryService.GetPackages(IRepository packageRepository, Boolean allowPrereleaseVersions, String[] filters, Int32 skip, Int32 take)

My VM has access to the internet, I downloaded UIPath from the VM. Ideas?


#8

hope you installed in local.
Could you please try to repair it or reinstall it and let me know how that goes.


#9

What do you mean by “local”?
I “reinstalled” it twice and the result was always the same (reinstall was in quotes because the installer does not look like a standard installer… no option is given to me, UIPath gets automatically deployed to “UserLocal” directories)


#10

Yes, that’s all I can see. I reinstalled it twice, it always come back with the same items in the list


#11
  • Can you access myget.org?
  • Please upload a screenshot with your package manager - available

#12

Hi ,
Please follow up the instruction mentioned by @badita.
I’m not sure this is the problem with UiPath community version or not, to check that can you please download “UiPath Studio” which is 60 days free trail mode and it has the standard installer wizard unlike community version which is just an exe.


#13

Yes, I can access myget… here are the screenshots


#14

Hi,

I’ve encountered the exact same problem - no other packages available other than “UiPath.Core.Activities”.
Had a different exception in the log though - I found several excpetions saying " (407) Proxy Authentication Required."
I’m in a network that needs proxy authentication so I’m assuming the package was not able to be downloaded.

So I’ve understood that the community edition won’t work for me. So I tried installing the 60 days trial version and this time it worked.

I’m okay with the 60day trial for now - but just wanted to share the same problem.

Regards,
Chihiro


Error on Orchestrator
#15

I’m having a problem seeing any of the extra packages (Excel, Mail, Database, etc.) in the Manage Packages dialog. I know for certain that my company forces us to use a proxy to connect to the Internet. An IDE like Pycharm allows me to provide the proxy in their package manager dialog box.

How can I see all the available packages if my company forces me to use a proxy?


#16

You can download them locally from here https://www.myget.org/feed/Packages/workflow (just create an account on myget)
Then add the local folder as a source in package manager.

Make sure to download the dependencies, too.


#17

That last line is the killer. Dependencies have dependencies have dependencies… and I’ll have to hunt for all of them and download? That’s a pretty cumbersome workaround.

So there is no way to configure UIPath Studio’s package manager to be proxy aware?


#18

I will find out. But it is just enough to download all the packages. Dependencies are automatically installed if they are found in the source folder.


#19

I’ve confirmed this works for me. I started by downloading the Excel package, added the folder where I saved it as a source within the package manager dialog, and then tried to install Excel from the package manager dialog. As it complained of each dependency, I went back to the site and downloaded that dependency into the same folder, then tried to install Excel again. Each time it complained about the next missing dependency, so I downloaded each dependency one by one, and repeated this process. Finally Excel installed after it had all its dependencies in my local source folder.

Thanks.

I’ll talk to my IT dept to see if I can get off this proxy, but I still think it would be a great feature for UIPath to do what JetBrains does, and allow a proxy to be configured in this package manager dialog.


#20

​Hi,

I created an account in myget.org and lo​gged in. the url path https://www.myget.org/feed/packages/workflow​ is not fetching me uipath packages.
I am taken to https://www.myget.org/, where it says “Create a feed to host and share packages with your team” and has a create new feed button beneath it
Is the navigation to this page changed?

Please help.

Thanks