Nupkg not found in Studio

Hi all! I’m having issue installing nupkg.

I’m using UiPath Studio Community License, trying to install UiPath.Slack.Activities and TwoStepAuthentication.Activities. However they won’t show up when I do search in Manage Packages - All Packages. I then attempted to manually download from Marketplace and defined package source folder pointing to the correct path but still won’t show up.

A friend of mine on Enterprise version are able to see them when he did a search in Manage Packages… That makes me wonder it there any restrictions in Community License vs. Enterprise when it comes to packages? Or did I miss any configurations?

Welcome to the UiPath Community @ecSC2

Make sure in the sources section of Manage Packages, you must select Marketplace as source to see the marketplace components in the All Package section

Hi rahulsharma,

Yes I did. In fact I’ve tried all available options but still no luck…

Hi @ecSC2 ,

I don’t think manage packages will work different for enterprise and community. It is not dependent on thr license.

If you successfully downloaded nupkg files from marketplace. Keep those nupkg files in your local folder and connect your manage packages feed to local folder where your packages downloaded and select check box local feed and try restart your studio and while import packages sele t local feed to get those packages. Please try and let us know. Thanks.

@ecSC2

Welcome to forums

After Installation can you check the Project and check the dependency is showing

Hope this will help you

Thanks

Hi kirankumar,

I’ve tried that as well. I’ve downloaded both nupkg from UiPath Marketplace and stored them in local folder. To properly test them out, I have 2 copies each, locate them in 2 different folders:

One set stored in D:/xxxx

Another set stored in UiPath default source folder: C:\users\xxx\AppData\Local\Programs\UiPath\Studio\Packages

Confirmed package source in manage packages but the downloaded nupkg just won’t show up… In fact, all the existing packages in UiPath Default Source Folder do appear except the two I manually saved…

Restarted both UiPath and my computer still not working… Maybe I need to reinstall Studio?

Hi Srini84,

The package just won’t appear… let alone dependency…

For clarity please see attached image

@ecSC2 Could you try placing the Slack Activities nupkg file under a Folder say Slack Activities under Packages folder?

Keep Individual nupkg files in Separate folders under Packages Folder.

Something like this :

Let us know if this Doesn’t work.

Hi @ecSC2 ,

Not sure why thse packages are not showing. Include pre release filter also may be these packages are preview ones. Just thought from my side. Thanks.

Hi @supermanPunch, @kirankumar.mahanthi1

Tried all… still not working…

Do Slack and TwoStepAuthentication show up when you search? If they do, then something must be wrong with my Studio… I’ll consider a reinstall.

Hi @ecSC2 ,

The Slack is available. As well as the TwoStep Authentiation packages.

Hi @supermanPunch,

Great! One last question. I believe your’s community license as well, can you please confirm? If that’s the case it pretty much confirms that my Studio is indeed bugged… I’ll have to schedule a reinstall.

@ecSC2 , I do have an Enterprise Trial License active for now.

But nevertheless, even with the Community License, it should be available.

However, Are other Packages from Marketplace available ?

Also, Could you Check what are the Options Selected in the Filter :

Hi @supermanPunch,

This thing just gets weirder…
I checked the filter but it didn’t give me much differences.

When I select Official as source it gives me many packages. However when I select Marketplace it says no package found, but after I left it for few minutes, 11 packages appeared, and that’s all…

It’s been 20min since and still the same 11 packages. Did a search Slack no result.

So after a whole lot searching and reinstalling UiPath I finally figured out the issue…

My automation process is set to use “Windows” under Compatibility option when first created and sure enough according to the 2021.10 release note and forum thread (link below), “Windows” compatibility option is using .NET 5. This explains why my Market Packages not showing the custom activities because they’re based on .NET 4 which is not compatible with .NET 5…

Going back to “Windows - Legacy” Compatibility option I’m able to find the activities I’ve been looking for including Slack and TwoStepAuthorisation.

Looks like UiPath have been looking into it since October but dead end?

1 Like

thanks for sharing the solution @ecSC2 . so we have to deal with the compatibility modes. if you select windows - legacy you are able to see the packages you referred. glad to know you resolved.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.