Cannot save the screenshot from 'Take Screenshot' activity while disconnect the Remote Desktop Connection


I want to use the unattended robot for taking the screenshot website.
Unfortunately, while I disconnected from Remote Desktop Connection, then I ran the process from UiPath Orchestrator but it didn’t save any files from ‘Take Screenshot’ Activity.

I tried to use the ‘Take Screenshot’ Activity by setting the Image variable and I used ‘Save Image’ Activity then the error was shown ‘Save Image: Object reference not set to an instance of an object.’. And after that I show file path from creating the variable of ‘Take Screenshot’, it’s empty string.

And … I tried to set the Robot Setting such as Logging settings, Session settings like resolution is 1920x1080 and dept is 32.

My question is

  1. My VPS is Windows10 but don’t have the license, is this the reason why unattended robot cannot take the screenshot if I disconnect from RDP???
  2. Is it possible to take the screenshot of VPS while disconnecting the RDP???

Thank you for reading this issue and hope anyone get the issue like me ;-;

Best Regards.

Hi @Onpinya.P

Yes ofcourse, you need License to run the process like Unattended mode in the RDP.

Is it the license of Windows 10 Operating System, Right?

NO @Onpinya.P

You need to buy the UiPath unattended license


But for now, I am getting the Community Plan.
I used to trigger the unattended robot, and it can run while disconnecting the RDP.
I don’t know why the ‘Take Screenshot’ cannot save anything on RDP.

Best Regards,

Check out the docs