Cannot run jobs from UiPath Orchestrator


I’ve been learning to use UiPath Orchestrator and have run into a roadblock.

I have created a machine, robot, process, and environment. Both the process and the robot are associated with the environment. I am able to run the process directly from the UiPath Robot on my PC after downloading it from Orchestrator. However, I am unable to run the process as a job via Orchestrator. The robot on the environment is not available to select when I try to run a job in Orchestrator.

Any advice would be appreciated. Thanks.

Job page


First you have to publish the package. First go to process tab and click add button to publish the package. After that go to job tab to run the process.


Hello @SimpleRookie

You have to assign the robot to the environment. Go to the environment page and assign the robot to that environment. Then you will be able to see the robot in the create job page

1 Like


Thanks for the input. Unfortunately, unless I did something wrong I have already assigned both the bot(s) and the process to the environment. But the bots do not show up on the job screen when I try to run the process. Do you have any other ideas?


Thank you. I have already published the package and it is available on the process tab / assigned to the environment. If you have any other ideas, I would greatly appreciate it.


Hello @SimpleRookie

Is this the community version of the orchestrator you are using? or is it an enterprise edition?

If this is the community edition, Could you change the robot type to “Development” and try again to see whether it is showing in create job window?

Thank you! I changed the robot type to “Studio” and that worked.

Interestingly I did not have “Development” as a robot option, though I’m using the community license for studio/orchestrator. Do you know if there is a difference between the “Studio” and “Development” robot types?

1 Like

I think Studio is referred to the development robot type :slight_smile:

It’s just a matter of renaming… no worries… after all, it is working… :slight_smile:

1 Like

I am still facing the same issue though I have done everything which need to do.please give me some solution

1 Like

You need to add the robot and the process to the same environment inorder to execute a job

I am having the same issue. Did you resolved it?

I’m also having the same problem.

Robot type is studio and is active
Environment is set up and assigned to Robot
Job published
Added to processes
And I’m not using the robot to access a remote server.

Please help.

To run a robot from Orchestrator, it must be unattended type now (i.e. will not work for studio robot). Change the robot type via Robots/Edit in Orchestrator and it shall fly.


Same issue here. I tried to change robot type from Studio to Unattended but it says “No available licenses: the number of new machine slots would exceed the total license count. (#1916)”. Is orchestrator not anymore available for CE users? Appreciate your inputs. Thanks!

There is still 1 unattended license in CE, so it is probably in use by you elsewhere. Check your license page.

Seriously? This lack of this little piece of information cost me 2 hours… Thanks for sharing, though!

Additionally, it is necessary to provide ANY password when changing the type of the robot to unattended. It looked as if I was provided with a password immediately, however this password evaluated to null later (which I found out through looking at the failure details in the job). Thereafter, I deleted the “provided” password and typed in “password” instead. Now, everything is working fine.


Thanks, unfortunately it still cant be updated it to Unattended. I decided to do it again by deleting machines registered and adding again. Unfortunately, I can’t now connect to Orchestrator. I have provided Machine key correctly. It says “Invalid machine key”.

It’s now working. I found out 2 machines were active under License>Unattended. I just disabled the other one. Thanks!

I updated to unattended and re-entered the password and it’s running now.

Thank you for your help.