Cannot make Click event capturing working - need help!

uiautomation
studio
p_qa

#1

I am trying to capture some data from an old Desktop UI application written on VB6. The idea is to attach UiPath Robot to an opened desktop application window, capture the button click event and, once that happens, to capture some data values from a number of data entry fields that are also in the window.

So far I was unable to intercept the clicking event. Tried User Events > Element Trigger > Click Trigger pointing to a button or a checkbox within the window. It didn’t work. Tried Element > Mouse > Click again targeting a checkbox within the client application window. No luck. All I’m trying to do at this stage is to simply write a Log messge when the event is intercepted. No matter what I click within the target desktop application - no sign of event interception.

Any ideas on what might be a reason for that not to work, or what to do to make it work?

I am on Windows 10. Target application is VB6 with windows forms in it.


#2

@Gnum,
To capture values please use Get Text Activity. (make sure you have right selector to capture accurate data. some times you need to use wiled key character to get right area)
To enable check box please use select item activity.
Hope my inputs are useful.


#3

Thank you for your reply!
It does not help with solving my problem though. The problem that I’m having the lack of event triggered by User clicking on a button, which would be followed by what you suggest. The event needs to be triggered first though, which is what not happening for me. User clicks the button - no reaction on UiPath robot part. Tried to configure it different ways - no event. The flow of the process stops at the Waiting For Event point and never moves from it onwards.

Any ideas on why would the be the case?


#4

@ddpadil please help @Gnum


#5

Hi,
Please make use User Agent wizard instead of using from Activity tab.

useragent

All the activity which falls under user agents must be used inside a Monitor Events activity.
Please take a look where I try to click on recycle bin using wizard and it automatically create a container involving monitor event activity and in the “event handler” container please use appropriate activity which need to be triggered when click happens on recycle bin.

clickEvent


#6

Thank you @ddpadil, it helped!
For some reason when user event capture is set from the “User Events” menu it works different even though looks the same in the IDE.

Regards,
Alex


#7

I’m having the exact same problem, windows form using .net 4.5, windows 7 os. When attempting to run through an activity or by the User Events >> On Click Element, it doesn’t recognize the form on my desktop. It recognizes anything behind it (it appears). When i drop all applications appearing behind it, it captures the desktop. Any help is greatly appreciated! Using the community version of this product…


#8

Hi Ross,

Is it a desktop app? Can you please try with Notepad as well?


#9

Is it possible to upload the workflow here and also a screenshot with the application?


#10

Good grief, I haven’t followed up on this…appreciate the responses. My issue was i had a 4k monitor, and set the resolution to its optimal settings (3840x2160), however, it made the text way too small so i updated the 'Make it easier to read what’s on your screen options (see picture below). When I did this, the recorder couldn’t read the application controls, it was like it was attempting to read the controls assuming the 100% option. In case this helps anyone who is running into the issue in the future, hope this helps. image


#11

The problem with the scale was fixed in 2018.2, please check the release notes:
“DPI and Zoom level Independent support
Previously, support for non-standard DPIs was limited. Some workflows could not properly run on a different DPI than the one they were designed in Studio. Now, workflows execute regardless of the design time DPI settings.”

For previous version of UiPath platform, you have to re-login after changing the screen resolution or scale. Also, on configurations with multiple monitors with different configurations for scale and resolution, the automation works only on the primary monitor for versions of UiPath Studio before v. 2018.2.