Cannot find “open browser” activity in Activities panel

Hi there,
I’m having the same issue, or very similar.

I’ve switched between StudioX license and regular Studio. I have a hunch it is related, as I’ve definitely got access to ApplicationCard, which can open a browser but you can’t save it to a variable.

I’ve also Uninstalled UiPath and reinstalled and its still not working. I’m using W10, but the same process was tried in a fresh install of Windows (this time Windows Server), and flipped between StudioX and Studio. And its the same issue. Arrghhhh!

Can anyone help?

Thanks :slight_smile:

Hi @Brendan_Neill

First, welcome to our UiPath Forum! :slight_smile:

Could you provide some details about your environment? I made a topic here that lists all possible things, but for now mostly a screenshot of your package manager in Studio, the Project Dependencies tab and your Studio version.

Thanks for the warm welcome and the reply. Here’s some of the requested details:

Studio 2020.2.0-beta.108 - 9/11/1953
Community License
EXE Installer

License Provider: Internal
Activation ID: UIP-e12938c6ec

Update Channel: Preview

Microsoft Windows 10 Enterprise 64-bit
.NET Framework Version 4.7.2 or later

“dependencies”: {
“UiPath.ComplexScenarios.Activities”: “[1.0.0-preview]”,
“UiPath.Excel.Activities”: “[2.8.1-preview]”,
“UiPath.Mail.Activities”: “[1.8.1-preview]”,
“UiPath.System.Activities”: “[20.2.0-preview]”,
“UiPath.UIAutomationX.Activities”: “[2.0.0-preview]”,
“UiPath.Word.Activities”: “[1.4.0-preview]”

I have been playing and have found that if I create a new Library in Studio that I can get access to OpenBrowser (yeeha!). Although I still really need to get this working. I did try all the suggestions above including deleting all AppData for all the users.

Thanks :slight_smile:

Hi @Brendan_Neill! Can you please add the UiPath.UiAutomation.Activities package as well to your project and try again? Thank you!

1 Like

Also, please bear in mind that the ‘Use Application/Browser’ card from UiAutomationX performs the same action as the ‘Open Browser’ activity from UiAutomation. What you have done is created a process using StudioX, then opened it in Studio, and expected to find the ‘Open Browser’ activity in the Activities Panel. We do not officially support StudioX projects with any other activity packages than the ones that are default.

1 Like

Thanks for the great suggestions. Busy atm. I’ll try this tomorrow some time and report back. Thanks again :slight_smile:


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.