Cannot create unknown type '{http://schemas.uipath.com/workflow/activities}ReadCsvFile

Hi
Someone Something ?
I am trying to run the bot from the batch file and I get such an error report: (I will add that the same robot from the UIstudio level goes without errors):

xxxxxxx System.Xaml.XamlObjectWriterException: Cannot create unknown type ‘{http://schemas.uipath.com/workflow/activities}ReadCsvFile’.
_ at System.Xaml.XamlObjectWriter.WriteStartObject(XamlType xamlType)_
_ at System.Xaml.XamlWriter.WriteNode(XamlReader reader)_
_ at System.Xaml.XamlServices.Transform(XamlReader xamlReader, XamlWriter xamlWriter, Boolean closeWriter)_
_ at System.Activities.XamlIntegration.FuncFactory1.Evaluate()_ _ at System.Activities.DynamicActivity.OnInternalCacheMetadata(Boolean createEmptyBindings)_ _ at System.Activities.Activity.InternalCacheMetadata(Boolean createEmptyBindings, IList1& validationErrors)_
_ at System.Activities.ActivityUtilities.ProcessActivity(ChildActivity childActivity, ChildActivity& nextActivity, Stack1& activitiesRemaining, ActivityCallStack parentChain, IList1& validationErrors, ProcessActivityTreeOptions options, ProcessActivityCallback callback)_
_ at System.Activities.ActivityUtilities.ProcessActivityTreeCore(ChildActivity currentActivity, ActivityCallStack parentChain, ProcessActivityTreeOptions options, ProcessActivityCallback callback, IList1& validationErrors)_ _ at System.Activities.ActivityUtilities.CacheRootMetadata(Activity activity, LocationReferenceEnvironment hostEnvironment, ProcessActivityTreeOptions options, ProcessActivityCallback callback, IList1& validationErrors)_
_ at System.Activities.Hosting.WorkflowInstance.ValidateWorkflow(WorkflowInstanceExtensionManager extensionManager)_
_ at System.Activities.Hosting.WorkflowInstance.RegisterExtensionManager(WorkflowInstanceExtensionManager extensionManager)_
_ at System.Activities.WorkflowApplication.EnsureInitialized()_
_ at System.Activities.WorkflowApplication.Enqueue(InstanceOperation operation, Boolean push)_
_ at System.Activities.WorkflowApplication.SimpleOperationAsyncResult.Run(TimeSpan timeout)_
_ at System.Activities.WorkflowApplication.BeginRun(AsyncCallback callback, Object state)_
_ at UiPath.Executor.RobotRunner.<>c__DisplayClass54_0.b__0()_
C:\Users\sant00\Desktop>pause

what’s going on ?

This is related to a missing package version on the runtime machine. I assume readcsv must be stored with UiPath.system.

You can check the package version either in your (2018.3) studio in dependencies or on your C drive (C:\Users%USER%.nuget\packages)

If you are running the job from a commandline batch script or something like that, there could be some issues like this. Last time I tested it, I got the same error where it couldn’t find the activities that it was dependent on.

I’m wondering if the UiRobot.exe is looking in the wrong location when run from commandline. If I identify a solution I’ll let you know.

[MatthiasVG]

Tx, but…
I have two identical files packages.config:

  1. C:\Program Files (x86)\UiPath\Studio
  2. C:\Program Files (x86)\UiPath\Studio\Packages
    with code:
<?xml version="1.0" encoding="utf-8"?>

What should I do with this knowledge?

The dependencies of your project are saved in the project json file, in the same file as your workflows.

The actual .nupkg packages are saved in the directory I mentioned earlier: C:\Users%user%.nuget\packages

[MatthiasVG]

Notes for earlier versions of NuGet:

NuGet 3.3 and earlier used a .nuget folder for solution-wide settings. This file is not used in NuGet 3.4+.
For NuGet 2.6 to 3.x, the computer-level config file on Windows was located in %ProgramData%\NuGet\Config[\{IDE}[\{Version}[\{SKU}]]]\NuGet.Config, where {IDE} can be VisualStudio, {Version} was the Visual Studio version such as 14.0, and {SKU} is either Community, Pro, or Enterprise. To migrate settings to NuGet 4.0+, simply copy the config file to %ProgramFiles(x86)%\NuGet\Config. On Linux, this previous location was /etc/opt, and on Mac, /Library/Application Support.

Bat…
Even if I find these settings, what should I do with it to make my script work

I will wait impatiently, but I do not promise I will not try to find a solution myself :wink:

Hi All

I found a solution to my problem :):muscle:

  • Click ‘SETUP\Publisch’ in Uipatch Studio and all working

Thank you for your commitment and best regards

Thanks @Slawek_Antoniewicz
I thought publishing might be the answer. Although, I tried it on my end yesterday and didn’t resolve the issue.
:thinking:
Least you got it working though, cause I don’t really need it right now.

1 Like