Cannot create unknown type '{}WriteCsvFile

Cannot create unknown type '{}WriteCsvFile
Hi all,

I am getting this error library error when I am running the bot using orchestrator.
I tried several ways to resolve it by using following ways but nothing seems to work :-

  1. Copied all the libraries which are mentioned in the Project.json file
    2)Tried to upload the libraries from orchestrator itself but getting an error as ‘Mentioned librabry version is already present’

Kindly help


Is it working normally? I mean without Orchestrator.

Yes. Locally it is working fine. So I tried to copy the libraries from local package folder to VM where the bot is running but still getting error. Not sure which exact package is missing. :frowning:

I got the solution for this issue :slight_smile: as follows :-

1)Copied uipath.excel.activities folder from source location to target VM where the bot was running(from/to packages folder).
2)After doing this I received error related to csvHelper library. I fixed that as well by copying it to the target location.

these two steps resolved my issue. :slight_smile:

Thanks all for sharing your views on this issue!!