Csv read activity crashed after upgrading to 18.2.3 version

robot

#1

Hi,

Found something wrong running csv read activity on uirobot.exe after updating to 18.2.3. It runs fine on studio, I already downloaded needed packages, but on robot I get the following message. Already uninstalled and installed, cleaned cache folder. Also try to change the UiPath.Excel.Activities version and still not working. Tried also to open worflow file, save as on version 18.2.3.

@badita @ovi


V2018.2 Release for Community
#2

Hi Ricardo,

The problem you have is that the flow cannot run because it cannot find that csv activity.
This could have 2 causes:

  1. I see that you are running the flow from command line, have you published the project at least once?
    The project.json dependencies are not added until you publish the project at least once. Please check project.json to see if the dependencies section has any records.
    If not, publish it.

  2. Another problem could be that the csv activity is taken from a feed that the robot does not know.
    If you added a custom feed in package manager from studio and taken the csv from there, you need to “tell” the robot that he must use that feed also.
    You can verify this by comparing the following 2 files

C:\Program Files (x86)\UiPath\Studio\nuget.config \ this is the config that contains all the feeds the robot uses when it tries to download activities.
C:\Users<YOUR_USER>\AppData\Roaming\NuGet\nuget.config \ this is the config that studio uses

If there is anything missing from the robot nuget config please copy it from the studio’s one, restart the service and try again.

Hope this helps,
-Andrei


#3

Very good @andreiT, the first option solved :slight_smile: just published the project on studio and then tried to run the project again using uirobot.exe

Thank you very much!

(that’s why I love UiPath, less than 1 day and you solved my problem, very good guys!)