Cannot communicate with IE browser

I was trying to automate in IE on Server 2012 R2 i am facing an error can you help me out.

Thank you

Hi @Vamsi_Nori

please share more details about the error

Source: Open Browser

Message: Cannot communicate with Internet Explorer browser.

Exception Type: UiPath.Core.BrowserOperationException

An ExceptionDetail, likely created by IncludeExceptionDetailInFaults=true, whose value is:
UiPath.Core.BrowserOperationException: Cannot communicate with Internet Explorer browser. ----> System.Runtime.InteropServices.COMException: Cannot communicate with Internet Explorer browser.
at UiPath.UiBrowserClass.Open(String bstrURL, UiBrowserFlags flag)
at UiPath.Core.Browser.Open(String url, Boolean privateSession, Boolean headlessSession, Boolean defaultSession)
— End of inner ExceptionDetail stack trace —
at UiPath.Core.Activities.ScopeActivity.EndExecute(NativeActivityContext context, IAsyncResult result)
at UiPath.Core.Activities.AsyncNativeActivity.BookmarkResumptionCallback(NativeActivityContext context, Bookmark bookmark, Object value)
at System.Activities.Runtime.BookmarkCallbackWrapper.Invoke(NativeActivityContext context, Bookmark bookmark, Object value)
at System.Activities.Runtime.BookmarkWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)


Try to add the webpage to trust list in Internet Setting.

yes i did still the error persists

check this

I have been through this link

  • Added Web Page to Trusted Sites

  • Did IE Troubleshooting

still no luck

If it is possible can you add it in local intranet

can you let me know how to do it

there is option in the left side of trusted sites

Did Adding to Intranet sites still no change

Please provide the version details


UiPath Studio Version : 2018.3.3 Enterprise Edition

Browser: Internet Explorer

Browser Version : 11.0.9600.19267

OS Version: Windows Server 2012 R2 Standard Evaluation

Try these steps

Tried both the options still no luck

Hi, have you solved this problem? I have the same problem. I’ve tried every method I could find online, but none of them worked.

Hi @sxintian

Could you give these handful topics a read? They all contain the solution to the same issue and hopefully will guide you to the solution:

I do faced this problem for a long while…recently in my client;s vdi…the problem is asusual. adding even other Uipath activities which made me in search other angle of this issue…

what I found is that it is the problem with the organization browser policies, which even effects your home page settings.
In my VDI - i cannot set my IE homepage as blank, instead org overwrites with its own webpage, that makes IE “cannot Communicate Browser” with Uipath

to this, I did:
Set my “Start Up” as “Start with previous session” in Internet options ( which i closed my last session a blank tab:stuck_out_tongue_winking_eye:), which my org let me to do so.
and close this session.
when i use Open browser with
it worked…

and beware to close the session as a blank tab

@saiteja8 I am having this same issue. I tried your solution and it worked once and now it is back to not working. Has anyone else found a solution to this issue. I have tried all the suggestions listed above.