"Cannot communicate with browser" appearing for Chrome

Hi,
I have been going through many of the solutions previously given for this age old issue, but none seem to work.
Studio Versions : 2018.4.2 & 2019.(something)

I am getting the below errors :

This error is preventing me from completing the level 3 certification.
Could you please suggest something.

1 Like

@SudipG,

use Internet Explorer and it is more feasible than chrome browser.

1 Like

Hi Lakshman,
The same thing is occuring for I.E. Although,yes, I should’ve started off with I.E!
Although, I was checking out a solution given where we have to fix the NativeMessaging.
Could you please elaborate how this is achieved as I have not worked with Native Messages before.

@SudipG,

Is uipath identifying browser elements or not ? where you are getting this error ?

THis is happening in the beginning. InitAllApplications – > Open Browser activity.
It launches the browser, then error pops up after 30 secs.
I have done the below:

  1. Explicitly given an “Attach Browser” (and later on “Attach Window”)
  2. Given Dynamic delay by Find Image on login screen
  3. Dead/Static delay between launch and next activity

None of the above worked.
Note : My code was running end-to-end fine till day before yesterday or so.

can you try to use element exists and find element for this instead of delay.?

@SudipG,

Do one thing. Use open browser activity and then pass URL of ACME systems. Then try to indicate username and password. check these things let me know. And also if it is not identifying then take screenshot and show me.

Hi Divya,

I tried all combinations but the error is coming DURING the execution of “Open Browser” activity itself and not the activities following it/inside it.
Please see the screenshot I have provided in the reply to Lakshman’s reply in the below comment.

I passed the ACME URL through a variable in open browser(as highlighted in pic below).
As you can see, “Open Browser Executing” appears in logs – > Error is thrown to user – > “Open Browser faulted”.

Note : Again, this is happening with I.E as well

@SudipG,

Are you used IE or chrome browser ?

If it is IE browser then uninstall UiPath and again re install it.

This is a “from long time” error i have seen with the Open Browser activity
Instead we could use “Open application” of iexplorer.exe / chrome.exe activity with “on element appears” activities for wait till ready features of the Open Browser…

This way could be just alter to Open Browser activity.

Hi Saiteja8,

I am facing the below error after using “Open Application”.
Do we have to manually set/assign values in “Properties”?
This happening at “Open Application” activity itself. Error "Value doesn’t fall within expected range"
Why is this type of out-of-bound-array/list error is showing ?
Properties:
FileName : “C:\Program Files (x86)\Google\Chrome\Application\chrome.exe”
Selector : provided selector of the login page
2

can you attach the xaml please…?

Hi,
I cannot upload xaml files and getting error “New users cannot upload attachment”
(Although all the above pics were attachments! seems to not work with xaml file)

See, it’s just a basic “Open Application” activity with “login page” identified from “Click to indicate on screen”.
No extra code is there.Problem is coming at basic level only.

Hi Sudip,

This is the xaml i tried now and is working for me to open iexplore.exe and open google home pageMain.xaml (7.9 KB)

Hi,

I’m getting the below error involving SelectorNotFound

Could you give a xaml with “Open Application” using Chrome. Lets see how it works from your end.I think my issue is with uipath studio itself. Code was working just fine about a week ago!

Hi Sudip,

Sorry for the late reply…
I even tried to re run the old workflows now, which were good before. They raised new exceptions…
Then I upgraded the packages and later workflows are good like earlier…

and with the chrome it worked well…when i tried to this link even Open Browser activity worked like before…

Just have a try…

Hi Saiteja,
Sorry for the late reply…
Could you be a bit more specific about what packages and how to update them.
From where?

Use the package manager to check for any updates