Building an orchestrator queue from a datatable

orchestrator
studio

#1

Hi,
I am trying to use an internally created, and filtered, datatable in order to build a queue within Orchestrator. When using Data Scraping I named two of the columns “Begin” and “Begin Link” respectively, with the former slightly meaningless, but latter containing the URL, and have tried to attribute this to the Queue Item:

Data scrape:
image
(Incomplete as no one has finished their inputs yet, but there is still info there etc, so shouldn’t matter)

Work queue ItemInformation collection:
image

However when running the job I get the following in Orchestrator:
image

I can’t find an instance where I have named something as such. This workflow was created by another developer and I’m troubleshooting, but have recreated the data scraping, and reworked the Add Work Queue Item - where else could I look? I checked the filter - no columns are removed?

There is a join between this datatable from the scraping, and that from an entity list, as follows:
image

I have also counted the number of columns brought in to the Queue (number of columns in the data table being used for “Add to Queue” activity), which is 5, so I’m wondering if certain columns have been missed, but can’t see anywhere they would have been removed. I have used log messaging and can see that BU Name, Code, Provision and Begin appear to be being pulled in (although Begin is blank). I have also tried logging results for Begin_Link (as an example - "Begin_Link is " + row(“Begin_Link”).ToString), BeginLink and Begin Link, and no logs are posted for these.

Please can someone help, as I’m truly stumped why I’m unable to add this info to the queue.

Thanks!


#2

You said that the data table is created internally.
How the column names are added in these two data tables?


#3

In the table they come from I used data scraping and named the relevant field Begin Link, nothing was named Begin_Link


#4

Okay.
Can you verify the ItemInformation of queue. If any of the field named as “Begin_Link”?


#5

I copied in a screenshot, you can see the columns, none are called Begin_Link? Or do you mean elsewhere?


#6

Sorrry, ItemInformation is already there. I missed it.

is “Begin Link” column exists in the out_DTWorkQueue data table?
Debug and see, if all 5 columns are appearing in the out_DTWorkQueue ?


#7

As far as I know Begin Link is, I used log messages to grab all columns (using same code as for the ItemInformation) and although the output was blank, Begin Link was showing as something which existed. When I was printing the 5 columns out Begin_Link isn’t one, I don’t know where it is :stuck_out_tongue:


#8

Strange behavior.
Can you check the list of columns in the dTFilteredUnitList and dtFilteredEntityList.
Somewhere it has to be defined.
While scraping did you edited the column headers like shown below -

image


#9

Entity comes from an Excel file we maintain as a control, and has no links in it, so I know it’s not from there, it contains dates, emails and completion status.

Unit list is the one I created using the wizard you just posted, and the one which contains the URL associated with the “Begin Link”, and I have recreated this myself, renaming the columns, for the relevant one I changed it to Begin for Text and Begin Link (no “_”) for the URL.

Essentially I recreated all steps involved in this, making sure not to use an _ anywhere. My thought is that UiPath “remembers” there being one from before and is still looking for it? I’m seeing similar with a completely unrelated issue where I’m using “read cell” activity and it’s still reading “Oct” even though the cell now says “Nov”, which weirdly can be read by “Excel application scope” - making it look like sometimes UiPath “remembers” odd/incorrect things?


#10

You are right. Sometimes robot behaves weird.
In the coming releases, hope for the more stable releases.

Just a thought:

  1. Scrap the data with only four columns. Leave the Begin Link.
  2. Scrap the same data again, this time only Begin Link.

And check what is happening.


#11

Thanks, I’ll try to rescrape just some single columns and check what pops out.

Stability seems to be an issue - I’ve had the bot unable to find an element which it’s found fine hundreds of times before, and then when you rerun without touching anything it finds it again, seems like it has a lot of temporary blips!