Bug/Issue with Copy and pasting activity from one xaml to another

While Copy pasting the activity in uipath community edition ,the uipath not responding and hanging ,it seems like a bug it is not fixed in the latest update also … is any other way to fix it ???

@yajiv please restart your system once.it will work.

Hi @yajiv
Welcome to uipath community
Yes you are right when we are trying to copy a activity and trying to paste it any where it wil hang for a while but thats not a issue of UiPath Studio buddy
its because of Computer disk usage and processing speed, if the server or the local machine connected is good with cpu performance this wont occur buddy
So stop all the background running process in task manager in your system and
clear the temp files so that the disk space gets cleared with temp files
Cheers @yajiv

1 Like

Actually ,i have been restrated several times…

thanks for the reply, but in high performance system it occurs… that’s why i raise the issue…

what version of community edition you are using buddy
is that a stable or beta version
Cheers @yajiv

2019.6.0 - 6/24/2019
Community Edition
Update Channel: Stable

have a view on this buddy
Hope this could help you

Cheers @yajiv

so were you able to copy paste now without any hang buddy
Cheers @yajiv

wait a sec, i will try and let u know…

Cheers @yajiv

Nope… it didn’t work :unamused:

Fine i was about to ping you
its there in new version as well
may be this will be notified by the uipath and actions will be taken soon
But i think its based on the server or machine in which is installed
even i have a server where the studio is installed which has no issue while copying and pasting
while if i try with my laptop its getting slower and it has less memory space when compared to the server that i was connecting previously
So it all matters with the memory space we have and the CPU Performance buddy
Make sure you have latest dot net version of 4.7.2 atleast

Hope this wuld help you
Cheers @yajiv

i will try on my another system ,and let you know :love_you_gesture:

Cheers @yajiv

issue is still on , even in high performance systems…

If some apps are launched, the copy behavior will be freezing.
In my case, the acroedit(http://www.acrosoft.pe.kr/acroedit/) is launched, the copy behavior is freezing about 30 seconds.

1 Like

in my case , i am using the microsoft excel only with uipath.
still the problem is not solved

Is there any update/solution for this issue? I am facing the exactly same issue.
I am running community version 2021.4.3. It is installed locally, the xaml file is stored locally.
Computer has good specs.
I already try, re-installing, deleting all packages, restarting…
I’ve tried monitoring the CPU and Memory usage, but they stay constant while uipath freezes.
The issue happens with old and new projects. And it happens with any activity (an empty sequence, for exemple).

For anyone still having this problem, if your activity contains other activities inside it ( ex: you try to copy a whole sequence). make sure that your destination project have all the dependencies necessary.

for example, I was trying to copy a parallel activity containing some get mail activity from a office 365 dependency, but the destination project didn’t have this dependency so the copy/paste wouldn’t work on the parallel activity… and there’s no error message anywhere telling you this.