Bot thinks it clicked on item but has not and continues

I have had this situation happen many times where the item of interest will highlight on the object such as an “OK” on a dialog box but the item is still open and the bot continues to failure. Does anyone know why this happens or how this can be avoided if at all?

Hi @AlienV

Bot will only do what it is trained for :grinning:

Please try click image or sending hot keys

Thanks,
Prankur

2 Likes

Hi Prankur,

Isn’t clicking on an OK box of a windows control the best practice. Why do you think it won’t work. I’ve tried mutiple selectors which red highlight the object.

Can you share a screenshot or code for selector?

Thanks,
Prankur

This is the OK button after updating in the System1 UpdateWorkItemflow. It works sometimes, but sometimes not.

<wnd app='iexplore.exe' cls='#32770' />

<wnd title='OK' />

This may happen because of click properties.

Please check sometimes Send Windows Messages and Simulate click may not work.

Thanks. I’ve changed the simulate click. Strange thing is that a lot of items that worked fine just stopped working. It would not seem odd if it were one or two things.

Another question you might know the answer to…

All of a sudden my Write Range activity is “currently in use”. It’s as if the item never closed on the last write. This didnt start happening until a few hrs ago and not it’s all the time?!

I couldn’t able to get your question. can you please explain in more detail.

Try marking Target > WaitForReady property to Complete in click activity.

Thanks I will. I saw another post to change to “None”, which I did in a lot of places. That was because I was experiencing almost 2 min execution between bot actions and others who had experienced this said to change WaitForReady to this. This slowness has happened quite a bit. I need a deeper understanding of this property.

Hi Alien ,

  1. first try to make the selector more dynamic .

  2. while you are using the click activity that time you can uncheck the “simulate Click” property from property panel of activity .

  3. you can use Click image activity as well.

may be this can help you.

For message boxes - such as “OK” popups - I would recommend adding a check for the existence of the popup using the “Element Exists” activity. If the popup still exists after the click, you can program in a Retry to click it again.

It wasn’t the selectors. This is strange. I’m back five days later and opened up my flows and the nonstop selector issues I was having have ceased! I haven’t changed anything. I had no issue when unit testing before. What could cause this? PC Fatigue?! :rofl:

I had rebooted a couple of times when I did have these issues too.