BOT orchestrator failing if devmachine is not open while its running


its a weird problem i am facing i developed a bot and its working fine when i run it in devmachine and published and run it from orchestrator for couple of times and ran perfectly fine moved to UAT testing now the problem starts its not able to find some selectors i fixed them and ran it on dev worked sent to orchestrator and run gives me the error its not able find selector if I don’t open the machine where its running but if i open runs perfectly fine.

please help what’s happening what should i do to fix this problem?

its running from dev fine if its open but not running when run it from orchestrator .

Hello @Nagisetty_Leela_Kanthi!

It seems that you have trouble getting an answer to your question in the first 24 hours.
Let us give you a few hints and helpful links.

First, make sure you browsed through our Forum FAQ Beginner’s Guide. It will teach you what should be included in your topic.

You can check out some of our resources directly, see below:

  1. Always search first. It is the best way to quickly find your answer. Check out the image icon for that.
    Clicking the options button will let you set more specific topic search filters, i.e. only the ones with a solution.

  2. Topic that contains most common solutions with example project files can be found here.

  3. Read our official documentation where you can find a lot of information and instructions about each of our products:

  4. Watch the videos on our official YouTube channel for more visual tutorials.

  5. Meet us and our users on our Community Slack and ask your question there.

Hopefully this will let you easily find the solution/information you need. Once you have it, we would be happy if you could share your findings here and mark it as a solution. This will help other users find it in the future.

Thank you for helping us build our UiPath Community!

Cheers from your friendly