Bot always unable to find the UI elements corresponding to selectors

So, I am using Firefox…but this also happened when I used Chrome and it captured selectors (for some reason, sometimes when I use Chrome, it can´t see individual selectors, but only the main screen, leaving the selector field blank and automatically capturing cursor position)

The visible cursor doesn´t even moves. I created two different activities for a field… it CLICKS over the field, and then it INPUTS on the field. Neither activity however shows any sort of interaction with that field, even if I delete the first or second activity.

19.3.0+Branch.master.Sha.5fdb43627d7d3c011018bb545ddf9470210d44a9

Source: Type Into ‘INPUT mZ2Q6m’

Message: Cannot find the UI element corresponding to this selector:

Exception Type: UiPath.Core.SelectorNotFoundException

An ExceptionDetail, likely created by IncludeExceptionDetailInFaults=true, whose value is:
UiPath.Core.SelectorNotFoundException: Cannot find the UI element corresponding to this selector: ----> System.Runtime.InteropServices.COMException: Cannot find the UI element corresponding to this selector:
at UiPath.UiNodeClass.FindFirst(UiFindScope scope, String nodeID)
at UiPath.Core.UiElement.FindFirst(FindScope scope, Selector selector)
— End of inner ExceptionDetail stack trace —
at UiPath.Core.Activities.ScopeActivity.OnFaulted(NativeActivityFaultContext faultContext, Exception propagatedException, ActivityInstance propagatedFrom)
at System.Activities.Runtime.FaultCallbackWrapper.Invoke(NativeActivityFaultContext faultContext, Exception propagatedException, ActivityInstance propagatedFrom)
at System.Activities.Runtime.FaultCallbackWrapper.FaultWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)

Maybe action is done when it’s still not loaded, just a guess, I may be completely wrong, it’s hard to tell with only this

of course, What else info do you need? Screenshots?

“Maybe action is done when it’s still not loaded”

both actions have a “delay before” of 1500 ms

edit: the screenshot shows a delay of 1000. So I added delays of 1500 before and after for all activities. Still, not working.

which action isn’t working ? The first ? You are using internet explorer ?

None. I first tried only the Input. As it didnt work, I inserted the CLICK activity before. Did not work either.

I am using Firefox. But at Chrome it does not work either.

Have you used attach ?

edit: yes, I did. I used the screen recorder to capture the clicks. (I answered no before, because as attack is automatic, I did not remember it)

Here, another part of the workflow which is not working either.

Hi @Rogerio_Penna,

Based on the screenshot, the patient id is dynamic, i hope it will be keep on changing.

can you cross check using the UiExplorer same selector are coming?

Regards,
Arivu

hi Arivu96.

Not sure how do you want me to cross check it. Or what selector you want me to check.

Let’s try with the BUSCA (search) selector, from the latest screenshot

right now, it’s selector is:
webctrl parentid=‘oX0Q62’ tag=‘IMG’

I changed the screen, came back to it, and “INDICATED ON THE SCREEN”
webctrl parentid=‘oX0Q83’ tag=‘IMG’

and again
webctrl parentid=‘oX0Q_3’ tag=‘IMG’


So yes, it seems it is changing. Is there anything that can be done?

Hi @Rogerio_Penna,

use UiExplorer to get any other unique attributes
else use below code
parentid=‘oX0@*’

Regards,
Arivu

@Rogerio_Penna

Use wildcards concept for dynamically changing selectors.

For more than one character, use “*” to replace that dynamic part and for one character only, use “?”.

Thanks. I guess I will have to check EACH selector to discover how many characters change in it, right?

From my non expert (in programming or RPA) point of view, RPAs should do that at least semi-automatically. Like, in debug mode, ask the user to reclick at items and UiPath would then automatically (after some 2-3 reloads, compare the selector codes and add “*” or “?” or “@” (arivu suggested using a @… what does the @ do compared to */? ??) where necessary.

ok, and repair function of the selector already does this.

so just to update for anyone else checking this thread in the future, do not manually replace selectors. Use the REPAIR function and ckick again at the same element. UiPath will automatically REPLACE the parts of the selector that change, with “*”

ok… BIG PROBLEM here…

that same element which was always oX0… now became dTIQa2

ALL characters changed!!!

What now?

Use Uiexplorer and check other properties

ok… I see nothing of interest here.

Maybe RPAs need a little more coding skills than advertised…

ps: I am not posting about the selector that completely changed. For some reason, THAT selector is static now.

But below, there is a *j5 selector that is always *j5, but for some reason, UiPath is not finding it, so as you said, I am looking at UiExplorer to discover what is the problem.

**

**

Hi @Rogerio_Penna,

Remove the parentid from the selector and add the title and aaname and try again

Regards,
Arivu :slight_smile:

Hmm, did not work, as the error message shows

Source: Click ‘DIV’
Message: Cannot find the UI element corresponding to this selector: webctrl aaname=’ Abrir’ title=‘SA Strategic Adviser’ tag='DIV’

FYI, this particular element (Abrir (open)) is inside a scrolling menu

so I tried to use an anchor… but UiPath will not find the anchor… :roll_eyes::confounded:

here is the anchor selector
<webctrl tag='LABEL' />

it doesn´t even validate…

Is the menu-entry “Abrir” visible at start?
If you can’t find reliable selectors,
you can try to navigate with keyboard-shortcut (tab, arrow or something like this)
or you try to “click image” activity…