Click Cannot find the UI element corresponding to this selector:

Hi All,

I am new to UiPath I have the following issue with the selector. I have tried both Edge and Firefox but no help.
I am using a dynamic selector with an input variable “ticketa” as shown in the screenshot below


when I run the selector it provides the above error


Strangely when I use the same attach browser at the top of the sequence it is working
Here it is working

whereas here is does not work

Could someone please let me know here I am going wrong?
P.S I seperated the attach browser for new tab just for test purpose. It was not working in the original attach browser hence I had to seperate it.


Hello @Ayyappa_Chinnu
try to log the selector and check where it is going wrong.
compare both working and not working selectors for any difference in main window selector

Hi akshay. Thank you for the reply . Could you please let me know the steps to log the selector.


Open the selector in UI Explorer and try to compare both. Check the parent is same?
if not replace with wildcard.


Hi Anand,

Thank you very much for the input. As you said after comparison I replaced them with * instead of the variable and it works… I am still confused why it was not working with the variable…


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.