Automation Fails as Unattended from Orchestrator - Elements not found

I am struggling with an automation that will find all the selector elements if I run from the studio and run if I log onto the bot’s server and start the automation with the agent. However if I start the automation using the Orchestrator the job will fail when it try’s to select the first element.

I am flummoxed. I have tried adjusting selectors, adjusting the bots setting for logon to console.
The beginning part of the code is copied from another process that runs with no issues.

Any ideas would be appreciated.


1 Like

Hey @Larry_Rogers

Did not any error screenshot please


Have you configured the User that the process is running under with an Unattended Robot including providing the Machine Login Credentials?

In order to run a foreground process successfully, this is required unless the Robot is part of the Cloud Robot Pool.



Hey @Larry_Rogers

Have you installed your robot as service mode? To run the unattended jobs you need to install the robot in service mode. Please see the following link to achieve the same.

Quick Update. So I went and downgraded then re-updated the System and Automation dependencies then re-published. And, it works.

Thanks all for the feedback and ideas.


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.