Attach window not working after start process

Hi guys, why is it that after i use start process to open up a file, the attach window activity that is placed after seems to be completely ignored? The automation stops at a click activity as it is unable to find the element it is looking for but the attached window is not even at the front when the automation gets stopped. Does anyone have any idea why is it so?

It probably is because the selector still contains the “Window Title” from the Indicate on Screen.
So, when you inspected if the window title was OSDisk (C:) but when the robot is running if you use the same selector to attach to OSDisk (D:) it will not attach.

I suggest you use Edit Selector option and try tweak this by using a wildcard (*). For example, OSDisk (*D)

If i’m understanding you correctly, what you are referring to is the title of the window i am trying to attach right? For instance, the window i am trying to attach is a SAP window, which usually has the user’s name. I have made sure to remove that portion of the selector but it still does not work…

That is correct. But it is difficult to troubleshoot without a image of the window header and the selector you use. You will probably resolve this issue quickly if you upload them.

I understand data can be confidential but you can blur our the senstive data.

The laptop which i am working on has no internet access so i have to take picture of it using my phone… im sorry if the quality is bad but this is the best i can do. I’ve blurred out most things as most of them may be sensitive data.

That aside, i’ve tried using this selector without the start process activity at the top and it seems to work fine (e.g. the window is getting attached properly).

Great it works now.

As you say, since it works without start process on top, you could check what was different in this selector vs. the one which had start process before it. That way you know which part of the selector caused this issue.
I am sure this will be good to know if you have to develop other processes on the same application in the future.

Hmmm i still can’t figure it out though… both the selector seems the same to me. I even re-indicated both of them and unchecked the “title” for both of them but still, it only works for the one without “start process” activity at the top.

1 Like

Hey @wasd,

Could you please confirm whether it is failing in attach window or the click activity inside it ?

Thanks :slight_smile:

Hi, it is failing at the click activity inside it, but the window is also not appearing on my screen

1 Like

Does the start process opening the app ?

Is it possible for you to share the xaml for easy debugging

Thanks :slight_smile:

hi, i cant share the xaml file as it is on my company work machine that does not have internet access… and yes, the start process does open the app.

1 Like

Okay fine, is there any specific reason for using start process instead of open applicaiton.

does both of them work the same? i just need to open one specific docx file thats all. As long as either one of them achieve the result im fine with it.

1 Like

It works the same and even more appropriate to the target element you are trying to perform actions on.

If you use open app, you don’t want to use a separate attach window instead process inside the same all the actions you need.

Thanks :slight_smile:

I just realized that open application is more for opening the application itself, rather than a specific file. What i am trying to do is open a docx file named “abc.docx” and after that, attach a window called “SAP”.

1 Like

yes understand, so why not to use open app for SAP ?

any constraints ?

Ahhh i see… thank you so much for your help!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.